php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65439 Build fails when compiled
Submitted: 2013-08-12 14:10 UTC Modified: 2013-08-21 08:01 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: me at umakantpatil dot com Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.5.1 OS: Ubuntu 12.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
8 + 13 = ?
Subscribe to this entry?

 
 [2013-08-12 14:10 UTC] me at umakantpatil dot com
Description:
------------
When you compile PHP 5.5.1 version build fails with error. I have tried to create build from root user.

I'm using maven 2.2.1 for building. I have done many previous versions but this version is somehow not working. Once I say mvn release:prepare it starts compiling PHP and midway it throws error.

Details about libs, system are as follows:-

OS:- Ubuntu 12.10.

Lib:- open-ssl 1.0, bzip2 1.0.6, curl 7.26.0, libjpeg 6b, libpng 1.5.2, freetype 2.4.4, gmp 5.0.1, mhash 0.9.9.9, libmcrypt 2.5.8, tidy 2009-03-25, libiconv 1.14, libxslt 1.2.26, libxml2 2.7.8, get text 0.18, icu 4.8

Enabled:- --with-apxs2=<dir path>/bin/apxs, --with-libxml-dir=<dir path>, --disable-short-tags, --with-openssl=<dir path>, --with-zlib, --with-bz2=<dir path>, --with-curl=<dir path>, --with-gd, --with-jpeg-dir=<dir path>, --with-freetype-dir=<dir path>, --with-png-dir=<dir path>, --enable-gd-native-ttf, --with-gettext=<dir path>, --with-gmp=<dir path>, --with-mcrypt=<dir path>, --with-mhash=<dir path>, --with-tidy=<dir path>, --with-xmlrpc, --with-iconv=<dir path>, --with-xsl=<dir path>, --with-zlib, --enable-bcmath, --enable-calendar, --enable-ftp, --enable-mbstring, --enable-posix=shared, --enable-soap, --enable-wddx, --enable-zip, --enable-exif, --enable-intl, --with-icu-dir=<dir path>, --without-pear, --enable-zend-signals




Expected result:
----------------
Successful PHP build 

Actual result:
--------------
[INFO] [INFO] Generating phar.php
[INFO] [INFO] /bin/bash: /home/user/php/target/src/build/shtool: Permission denied
[INFO] [INFO] /bin/bash: /home/user/php/target/src/build/shtool: Permission denied
[INFO] [INFO] /bin/bash: -d: command not found
[INFO] [INFO] make: *** [ext/phar/phar.php] Error 127
[INFO] [INFO] ------------------------------------------------------------------------
[INFO] [ERROR] BUILD ERROR
[INFO] [INFO] ------------------------------------------------------------------------
[INFO] [INFO] make returned an exit value != 0. Aborting build; see command output above for more information.
[INFO] [INFO] ------------------------------------------------------------------------
[INFO] [INFO] For more information, run Maven with the -e switch
[INFO] [INFO] ------------------------------------------------------------------------
[INFO] [INFO] Total time: 20 minutes 12 seconds
[INFO] [INFO] Finished at: Mon Aug 12 06:32:09 PDT 2013
[INFO] [INFO] Final Memory: 40M/96M


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-08-21 07:51 UTC] me at umakantpatil dot com
This is not bug. Sorry for reporting. This was happening because of wrong file permissions. Please close/invalidate this ticket.
 [2013-08-21 08:01 UTC] mike@php.net
-Status: Open +Status: Not a bug
 [2013-08-21 08:01 UTC] mike@php.net
.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 23 04:01:25 2020 UTC