php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65407 Indicated default for opcache.enabled is incorrect in php.ini-*
Submitted: 2013-08-07 01:49 UTC Modified: 2013-10-04 16:35 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: stephen at stecman dot co dot nz Assigned:
Status: Not a bug Package: opcache
PHP Version: master-Git-2013-08-07 (Git) OS:
Private report: No CVE-ID: None
 [2013-08-07 01:49 UTC] stephen at stecman dot co dot nz
Description:
------------
Zend OPcache is enabled by default, however php.ini-* indicates that it is off by 
default:

; Determines if Zend OPCache is enabled
;opcache.enable=0

All of the other opcache.* options have their defaults indicated, so this is a 
little misleading.


Patches

correct_php_ini_opcache_enabled_default (last revision 2013-08-07 01:53 UTC by stephen at stecman dot co dot nz)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-04 16:35 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2013-10-04 16:35 UTC] krakjoe@php.net
It's enabled by default; if there is no php.ini found it is enabled, obviously the values in the php.ini in use take precedent over software defaults.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Aug 11 00:01:26 2020 UTC