php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65404 OO with screen of death
Submitted: 2013-08-06 13:34 UTC Modified: 2013-08-06 14:00 UTC
From: info at djdb dot be Assigned:
Status: Not a bug Package: Output Control
PHP Version: Irrelevant OS: win (irrelevant)
Private report: No CVE-ID: None
 [2013-08-06 13:34 UTC] info at djdb dot be
Description:
------------
file--1
$myobject = new object1();
class object1{
...
}
file--2
$myobject = new object2();
include(file--1)
class object2{
...
}

so the name of variable of instanties arr the same but no error message is write
so i was many time watching wat there was wrong (the file was to big to place them here)


Test script:
---------------
file--1
$myobject = new object1();
class object1{
...
}
file--2
$myobject = new object2();
include(file--1)
class object2{
...
}



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-08-06 14:00 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2013-08-06 14:00 UTC] johannes@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Variables can be reassigned.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 01:03:44 2023 UTC