php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65377 fatal error: ext/mysqlnd/mysqlnd.h: No such file or directory
Submitted: 2013-08-02 08:43 UTC Modified: 2013-08-02 10:07 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: php at mike2k dot com Assigned:
Status: Not a bug Package: mysqlnd_ms (PECL)
PHP Version: 5.4.17 OS: Ubuntu 12.04.2 precise
Private report: No CVE-ID: None
 [2013-08-02 08:43 UTC] php at mike2k dot com
Description:
------------
Using php5 5.4.17-1~precise+1 (from the ondrej/php5-oldstable PPA)

The php5-mysqlnd PECL module is also installed from this repo too.

Tried to issue "pecl install mysqlnd_ms" since there is no PPA for this yet (I 
prefer to use repos wherever possible.)

result is this: "ext/mysqlnd/mysqlnd.h: No such file or directory"

Looks like this MAY be related to https://bugs.php.net/bug.php?id=54644 but it's 
not exactly.

Expected result:
----------------
Standard PECL installation happening.

Actual result:
--------------
root@test:~# pecl install mysqlnd_ms 
downloading mysqlnd_ms-1.5.2.tgz ...
Starting to download mysqlnd_ms-1.5.2.tgz (385,916 bytes)
..............................................................................do
ne: 385,916 bytes
36 source files, building
running: phpize
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
building in /tmp/pear/temp/pear-build-root1clnDp/mysqlnd_ms-1.5.2
running: /tmp/pear/temp/mysqlnd_ms/configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -
I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -
I/usr/include/php5/ext/date/lib
checking for PHP extension directory... /usr/lib/php5/20100525
checking for PHP installed headers prefix... /usr/include/php5
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate 
PHP parsers.
checking for gawk... gawk
checking whether to enable mysqlnd_ms support... yes, shared
checking whether to enable table filter in mysqlnd_ms... no
checking whether to query caching through mysqlnd_qc in mysqlnd_ms... no
checking how to print strings... printf
checking for a sed that does not truncate output... (cached) /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert x86_64-unknown-linux-gnu file names to x86_64-unknown-
linux-gnu format... func_convert_file_noop
checking how to convert x86_64-unknown-linux-gnu file names to toolchain 
format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking for gawk... (cached) gawk
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared 
libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating ./config.status
config.status: creating config.h
config.status: executing libtool commands
running: make
/bin/bash /tmp/pear/temp/pear-build-root1clnDp/mysqlnd_ms-1.5.2/libtool --
mode=compile cc  -I. -I/tmp/pear/temp/mysqlnd_ms -DPHP_ATOM_INC -
I/tmp/pear/temp/pear-build-root1clnDp/mysqlnd_ms-1.5.2/include -
I/tmp/pear/temp/pear-build-root1clnDp/mysqlnd_ms-1.5.2/main -
I/tmp/pear/temp/mysqlnd_ms -I/usr/include/php5 -I/usr/include/php5/main -
I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -
I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c 
/tmp/pear/temp/mysqlnd_ms/php_mysqlnd_ms.c -o php_mysqlnd_ms.lo
libtool: compile:  cc -I. -I/tmp/pear/temp/mysqlnd_ms -DPHP_ATOM_INC -
I/tmp/pear/temp/pear-build-root1clnDp/mysqlnd_ms-1.5.2/include -
I/tmp/pear/temp/pear-build-root1clnDp/mysqlnd_ms-1.5.2/main -
I/tmp/pear/temp/mysqlnd_ms -I/usr/include/php5 -I/usr/include/php5/main -
I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -
I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c 
/tmp/pear/temp/mysqlnd_ms/php_mysqlnd_ms.c  -fPIC -DPIC -o 
.libs/php_mysqlnd_ms.o
/tmp/pear/temp/mysqlnd_ms/php_mysqlnd_ms.c:28:33: fatal error: 
ext/mysqlnd/mysqlnd.h: No such file or directory
compilation terminated.
make: *** [php_mysqlnd_ms.lo] Error 1
ERROR: `make' failed
root@test:~#

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-08-02 08:53 UTC] php at mike2k dot com
Also - tried this with other versions, every single one I tried still had the same 
issue.

1.5.2, 1.4.2, 1.4.1, 1.3.2, etc...

Thought maybe the newest version might have a specific dependency on PHP core 
5.5.x now.
 [2013-08-02 10:04 UTC] johannes@php.net
please check whether there's a php-mysql-dev package or similar. the required headers files 
have to very provided somehow.

with vanilla php they are part of the normal install process. if you can't find mysqlnd.h please 
talk to your package.
 [2013-08-02 10:07 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2013-08-02 10:07 UTC] johannes@php.net
talk to the packager ... talking to the package obviously won't help (except to answer the 
philosophical question on how one speaks to virtual data ;))
 [2013-08-08 05:38 UTC] php at mike2k dot com
Would like to say that Ondrej has fixed his php5-dev Debian/Ubuntu package to have 
the headers, and also now has a "php5-mysqlnd-ms" Debian/Ubuntu package on his PPA 
as well (http://dotdeb.org) - originally I had not really wanted to file this as a 
bug on PHP's part, but possibly have it require less of a dependency or something.

Anyway I think this might help a handful of people out now.
 [2013-08-08 05:39 UTC] php at mike2k dot com
Sorry - http://debphp.org/ is his website with information about the PPA/repos.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 22:01:24 2020 UTC