php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65348 CURLOPT_VERBOSE does not work with CURLINFO_HEADER_OUT
Submitted: 2013-07-26 23:43 UTC Modified: 2013-11-08 00:33 UTC
Votes:7
Avg. Score:4.1 ± 1.0
Reproduced:6 of 6 (100.0%)
Same Version:2 (33.3%)
Same OS:1 (16.7%)
From: danielkurecka at gmail dot com Assigned:
Status: Wont fix Package: cURL related
PHP Version: Irrelevant OS: *
Private report: No CVE-ID:
Password:
Status:
Package:
Bug Type:
Summary:
From: danielkurecka at gmail dot com
New email:
PHP Version: OS:

 

 [2013-07-26 23:43 UTC] danielkurecka at gmail dot com
Description:
------------
When CURLINFO_HEADER_OUT is set to TRUE than CURLOPT_VERBOSE does not work.

Test script:
---------------
$ch = curl_init('example.com');
curl_setopt($ch, CURLINFO_HEADER_OUT, TRUE);
curl_setopt($ch, CURLOPT_VERBOSE, TRUE);
curl_exec($ch);

Expected result:
----------------
Verbose information should be printed.

Actual result:
--------------
Nothing is printed.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-11-08 00:33 UTC] pierrick@php.net
-Status: Open +Status: Wont fix
 [2013-11-08 00:33 UTC] pierrick@php.net
Internally CURLINFO_HEADER_OUT uses CURLOPT_VERBOSE along with CURLOPT_DEBUGFUNCTION. 

I don't see any simple way of making this work without adding new structure to store the status of the userland CURLOPT_VERBOSE. Since CURLOPT_VERBOSE is mostly for a debugging puropose I rather not fix it.

If someone have a valid case where VERBOSE must work with CURLINFO_HEADER_OUT, reopen this and I will try to give a deeper look.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC