php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6534 problem while inserting accented character whith OCI
Submitted: 2000-09-04 14:27 UTC Modified: 2006-07-17 08:36 UTC
From: guenault at cstech dot fr Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.2 OS: Sun OS 5.7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
24 + 23 = ?
Subscribe to this entry?

 
 [2000-09-04 14:27 UTC] guenault at cstech dot fr
First Problem :
I try to insert accented characters values into a table using OCI and PHP4.0.2
the characters ? became i , ? became h ...etc.....
When i do the same query using sql+ there are no problem 
 - this  problem have been solved using htmlentities to convert accented chars to html and decoded in oracle using a stored procedure.

Second problem :
When i maque a select query on values that are accented,  accent desapear :  for exemple "r?sum?" is stored in the table and the query return "resume"

Do you have ever heard about this problem ?

Thanks a lot you make a very good job !

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-05 08:23 UTC] thies@php.net
please set your NLS_LANG to something meaningful in your apache startup script.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Sep 27 21:05:53 2022 UTC