php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6526 Unable to build DSO module for RH6.1
Submitted: 2000-09-04 06:42 UTC Modified: 2000-11-23 19:16 UTC
From: ron dot ekins at rdel dot co dot uk Assigned:
Status: Closed Package: Oracle related
PHP Version: 4.0.2 OS: Linux Redhat 6.1
Private report: No CVE-ID: None
 [2000-09-04 06:42 UTC] ron dot ekins at rdel dot co dot uk
I can build a DSO apache server and add support for PHP3.0.16 & PHP4.0.2 with oracle under Redhat 6.2.

But under Redhat 6.1 I can not build a DSO Apache server with PHP3 or PHP4 with oracle enabled.

A static PHP installation is OK but then I can't have both PHP3 & PHP4 on the same server.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-04 10:55 UTC] sniper@php.net
Including some more info like configure lines and 
versions of apache, etc. and possible error messages
would help a lot..

--Jani


 [2000-09-05 04:57 UTC] sniper@php.net
User feedback:
-------------
Apache 1.3.11 was configured with:-

configure --with-layout=Apache --prefix=/usr/local/apache
--enable-module=rewrite --enable-shared=rewrite
make
make install

At this point the DSO Apache server is ok.

PHP3 & PHP4 was then configured with

configure --with-apxs --with-oracle --with-xml --enable-track-vars --with-gd
make
make install

Apache will now not start unless the PHP modules are removed from the
httpd.conf.

The above procedure works under RH6.2 but not RH6.1.
 [2000-11-23 19:16 UTC] sniper@php.net
How did I miss this before..you must use --enable-versioning with both
php4 and php3 configures.

--Jani
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Mar 08 02:01:26 2021 UTC