php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65216 Missing documentation for SQLite3Stmt::readOnly()
Submitted: 2013-07-07 08:38 UTC Modified: 2016-06-27 11:57 UTC
Votes:4
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: bohwaz at yop dot kd2 dot org Assigned: cmb (profile)
Status: Closed Package: Documentation problem
PHP Version: 5.5.0 OS: N/A
Private report: No CVE-ID: None
 [2013-07-07 08:38 UTC] bohwaz at yop dot kd2 dot org
Description:
------------
The readOnly() method of the SQLite3Stmt introduced in PHP 5.3.5 (see http://marc.info/?l=php-cvs&m=129381345831697 ) doesn't appear in the documentation: http://au1.php.net/sqlite3stmt

It seems that SQLite3::createCollation introduced in 2012 (see https://bugs.php.net/bug.php?id=60871 ) is also missing, but I don't know if this one actually made it to a PHP release.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-04-21 00:48 UTC] bohwaz at grr dot la
createCollation() is now included in documentation but I found another missing one: openBlob().
 [2016-06-27 10:52 UTC] cmb@php.net
-Status: Open +Status: Verified -Assigned To: +Assigned To: cmb
 [2016-06-27 10:52 UTC] cmb@php.net
Actually, SQLite3Stmt::readOnly() is available as of PHP 5.3.6,
see <https://3v4l.org/UAthI>.

And yes, the as of yet undocumented SQLite3::openBlob() is
available as of PHP 5.3.0, see <https://3v4l.org/ur4RS>.
 [2016-06-27 11:57 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=339507
Log: Fix #65216: Missing documentation for SQLite3Stmt::readOnly()
 [2016-06-27 11:57 UTC] cmb@php.net
-Status: Verified +Status: Closed
 [2016-06-27 11:57 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2020-02-07 06:07 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=2e9c07ed8ff0ce17d7933ba3cac3e237949cae4a
Log: Fix #65216: Missing documentation for SQLite3Stmt::readOnly()
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 12:03:36 2021 UTC