php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65139 http 500
Submitted: 2013-06-27 02:05 UTC Modified: 2013-07-05 01:59 UTC
From: chromegame at 163 dot com Assigned:
Status: Not a bug Package: opcache
PHP Version: 5.5.0 OS: windows2008r2
Private report: No CVE-ID: None
 [2013-06-27 02:05 UTC] chromegame at 163 dot com
Description:
------------
I downloaded the php-5.5.0-nts-Win32-VC11-x64.zip, when I was normal in the local 
test in windows2012, a server windows2008r2 is normal, but in another server 
windows2008r2, it appears that the HTTP 500 internal server error, also did not 
appear any other tips, when I will opcache.enable=0 or directly delete 
ext\php_opcache.dll, normal, summarizes the reasons, as long as the open OPC, PHP 
cannot run, HTML can open, is this why?
My configuration is as follows:


Test script:
---------------
[opcache]
zend_extension=php_opcache.dll
opcache.enable=1
opcache.enable_cli=0
opcache.memory_consumption=256
opcache.interned_strings_buffer=16
opcache.max_accelerated_files=6000
opcache.max_wasted_percentage=60
opcache.use_cwd=1
opcache.validate_timestamps=1
opcache.revalidate_freq=2
opcache.revalidate_path=0
opcache.save_comments=0
opcache.load_comments=1
opcache.fast_shutdown=1
opcache.enable_file_override=0
opcache.optimization_level=0xffffffff
opcache.dups_fix=0
opcache.blacklist_filename=
opcache.max_file_size=0
opcache.consistency_checks=0
opcache.force_restart_timeout=180
opcache.error_log=
opcache.log_verbosity_level=1
opcache.preferred_memory_model=
opcache.protect_memory=0
opcache.mmap_base=NULL



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-07-03 22:05 UTC] felipe@php.net
-Status: Open +Status: Feedback
 [2013-07-03 22:05 UTC] felipe@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2013-07-05 01:41 UTC] chromegame at 163 dot com
-Status: Feedback +Status: 打开
 [2013-07-05 01:41 UTC] chromegame at 163 dot com
I have solved this problem, through the investigation step by step, it is my 
mistake, because before has been using the old php.ini, after changing into 5.5.0, 
forget to change this place, caused opcache to open php.exe cannot run, /*** 
session.save_path = "C:\Windows\Temp" */ please forgive this problem submitted by 
me, is my own mistakes.
 [2013-07-05 01:59 UTC] felipe@php.net
-Status: 打开 +Status: Not a bug
 [2013-07-05 01:59 UTC] felipe@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 21:01:24 2020 UTC