php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65067 Please apply dbsetopt fix from #63258 to PHP 5.4
Submitted: 2013-06-19 19:48 UTC Modified: 2013-06-20 19:54 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: jwatson at fh dot org Assigned: ssufficool (profile)
Status: Closed Package: PDO related
PHP Version: 5.4.16 OS: Ubuntu 12.04
Private report: No CVE-ID: None
 [2013-06-19 19:48 UTC] jwatson at fh dot org
Description:
------------
The bug reported in #63258 was fixed in

http://git.php.net/?p=php-
src.git;a=commit;h=0c0b5a3543f37dc3dfe7fa55629f2749c0b05294

However, it appears the fix was only applied to PHP 5.5, which does not help those 
of us who are experiencing the bug with PHP5.4 or earlier. Please apply the bugfix 
to PHP5.4 since that version is still under active development and officially 
supported.

Thank you all for your work! You are all so very appreciated!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-06-20 14:09 UTC] laruence@php.net
-Assigned To: +Assigned To: ssufficool
 [2013-06-20 14:09 UTC] laruence@php.net
hmm, according to the feedback at #63258 this may cause #63638

@ssufficool do you think we should merge this into 5.4?
 [2013-06-20 16:03 UTC] jwatson at fh dot org
I think you have it backwards. The #63258 fix does not cause #63638. The fix 
implemented for #63258 resolves #63638. This is noted at the bottom of the ticket 
you mentioned. @ssufficool identifies #63638 as one of the tickets that is 
resolved by his patch.

I can understand the confusion though, since there are so many duplicate tickets 
reporting the same issue.
 [2013-06-20 17:46 UTC] jwatson at fh dot org
This ticket can be closed. There was a problem in github that was preventing me 
from seeing the code that was already checked-in for PHP 5.4.17. It appears @ 
ssufficool already applied the patch to PHP5.4.17. I was just not able to see it 
in github.
 [2013-06-20 19:54 UTC] jwatson at fh dot org
-Status: Assigned +Status: Closed
 [2013-06-20 19:54 UTC] jwatson at fh dot org
Closing ticket.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 01:03:40 2021 UTC