php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64965 phpmyadmin doesn't start - error php
Submitted: 2013-06-03 18:28 UTC Modified: 2013-06-04 02:46 UTC
From: marcelo dot pontarelli at vodafone dot it Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 5.4.15 OS: windows xp sp2
Private report: No CVE-ID:
 [2013-06-03 18:28 UTC] marcelo dot pontarelli at vodafone dot it
Description:
------------
Trying to launch phpmyadmin from XAMPP:

Fatal error: Call to undefined function mb_detect_encoding() in C:\xampp\phpMyAdmin\libraries\php-gettext\gettext.inc on line 177

--- part affected ----

 * Convert the given string to the encoding set by bind_textdomain_codeset.
 */
function _encode($text) {
    $source_encoding = mb_detect_encoding($text);
    $target_encoding = _get_codeset();
    if ($source_encoding != $target_encoding) {
        return mb_convert_encoding($text, $target_encoding, $source_encoding);
    }
    else {
        return $text;
    }
}



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-06-03 18:39 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2013-06-03 18:39 UTC] pajoye@php.net
Enable the mbstring extension in your php.ini and this error will disappear. 
Please use the php-install, php-general or php-windows mailing list for further 
support questions.
 [2013-06-04 02:46 UTC] marcelo dot pontarelli at vodafone dot it
Enable the mbstring extension in your php.ini and this error will disappear. 
Please use the php-install, php-general or php-windows mailing list for further 
support questions.
-->>
Error seems corrected.
message from xampp: 'mbstring extension already loaded' when enabling 'mbstring.dll' extension.

This outputs another message:
'browscap.ini' in 'php/extra' already missing.

Copied file from 5.4.14 and now it works fine.
Thanks
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 02:02:11 2014 UTC