php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #64807 Incorrect Version on read_exif_data() alias
Submitted: 2013-05-09 21:43 UTC Modified: 2013-05-16 19:37 UTC
From: rlerne at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rlerne at gmail dot com
New email:
PHP Version: OS:

 

 [2013-05-09 21:43 UTC] rlerne at gmail dot com
Description:
------------
This Page:

http://us1.php.net/manual/en/function.read-exif-data.php

Shows this version: (PHP 4 >= 4.0.1, PHP 5)

Which is an alias of:

http://us1.php.net/manual/en/function.exif-read-data.php

Which shows version: (PHP 4 >= 4.2.0, PHP 5)


Exif doesn't seem to have any functions prior to 4.2.0, unless this was a "preimplemented function" that now wraps exif_read_data?


Seems this bug was reported previously, but was closed:

https://bugs.php.net/bug.php?id=24157



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-05-16 19:37 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2013-05-16 19:37 UTC] aharvey@php.net
ext/exif was added in PHP 4.0.1: https://github.com/php/php-src/commit/3c61d015c28d053e3cfaa9e5fd439bfae66982d9 (you can track that back to the NEWS at the time, which was for 4.0.1-dev).
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 15 11:01:24 2021 UTC