php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64617 --with-pcre-regex doesn't scan subdirectories
Submitted: 2013-04-09 21:00 UTC Modified: 2013-06-07 11:25 UTC
From: php at paulisageek dot com Assigned:
Status: Not a bug Package: PCRE related
PHP Version: 5.4.13 OS: unix
Private report: No CVE-ID: None
 [2013-04-09 21:00 UTC] php at paulisageek dot com
Description:
------------
on my machine (CentOS) the libpcre.a is in /usr/lib64/ and the pcre.h is in 
/usr/include

If I try --with-pcre-regex=/usr then it can't find the library.


Test script:
---------------
./compile --with-pcre-regex=/usr

Expected result:
----------------
It compiles.

Actual result:
--------------
checking for PCRE library location... configure: error: Could not find libpcre.
(a|so) in /usr


Patches

search_pcre_in_common_installation_directories.patch (last revision 2015-08-25 11:29 UTC) by rainer-phpbugs at 7val dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-04-10 00:58 UTC] aharvey@php.net
-Status: Open +Status: Feedback
 [2013-04-10 00:58 UTC] aharvey@php.net
Does --with-libdir=lib64 allow configure to work?
 [2013-06-06 15:14 UTC] kovtun at complex dot lviv dot ua
No, it doesn't help

./configure --prefix=/usr/local/php54  --with-pcre-regex=/usr   --with-libdir=lib64
.........
checking for PCRE headers location... /usr/include
checking for PCRE library location... configure: error: Could not find libpcre.(a|so) in /usr



# dpkg -l |g pcre
ii  libpcre3                         8.12-3ubuntu2                           Perl 5 Compatible Regular Expression Library - runtime files
ii  libpcre3-dev                     8.12-3ubuntu2                           Perl 5 Compatible Regular Expression Library - development files
ii  libpcrecpp0                      8.12-3ubuntu2                           Perl 5 Compatible Regular Expression Library - C++ runtime files


# find /usr/ -name "libpcre.so"
/usr/lib/x86_64-linux-gnu/libpcre.so


# find /usr/ -name "libpcre.a"
/usr/lib/x86_64-linux-gnu/libpcre.a
 [2013-06-06 15:15 UTC] kovtun at complex dot lviv dot ua
php-5.4.15 version
 [2013-06-06 17:42 UTC] ab@php.net
ln -s /usr/lib/x86_64-linux-gnu/libpcre.a /usr/lib/libpcre.a

But why would you want to use 8.12 when bundled is 8.32?
 [2013-06-06 17:43 UTC] ab@php.net
Also i wouldn't say this is a bug, looking into non standard dirs is ignored by 
many projects.
 [2013-06-07 07:20 UTC] kovtun at complex dot lviv dot ua
> But why would you want to use 8.12 when bundled is 8.32?

because 8.12 is current version in ubuntu-11.10


> ln -s /usr/lib/x86_64-linux-gnu/libpcre.a /usr/lib/libpcre.a

Thank You. It works.

>Also i wouldn't say this is a bug, looking into non standard dirs is ignored by many projects.

sorry, I just don't have much experience and I don't know that /usr/lib/x86-64-linux-gnu/ is non-standard directory..
 [2013-06-07 11:25 UTC] ab@php.net
-Status: Feedback +Status: Not a bug
 [2013-06-07 11:25 UTC] ab@php.net
Here's the standard *nix directory structure 
http://en.wikipedia.org/wiki/Unix_directory_structure

Since you compile it yourself, you still could benefit from a better PCRE in PHP. 
That wouldn't affect anything on your system.
 [2015-08-25 11:33 UTC] rainer-phpbugs at 7val dot com
This is a problem with the pcre supplied with w.g. Ubuntu 15.04, and similariy in SuSE 13 or Redhat Enterprise Linux 7. While the former has /usr/lib/x86_64-linux-gnu/libpcre.so, the latter both have it in /usr/lib64.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC