php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64564 pg_trace corrupts memory and crashes server
Submitted: 2013-04-02 10:48 UTC Modified: 2013-06-05 13:38 UTC
From: php at compressedtime dot com Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 5.3.3 OS: Linux
Private report: No CVE-ID: None
 [2013-04-02 10:48 UTC] php at compressedtime dot com
Description:
------------

When I use pg_trace on my Linux server I got a lot of segmentation faults in the 
error_log.

PHP 5.3.3 (cli) (built: Feb 22 2013 02:37:06)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies



Here's a backtrace from a core file:

#0  0x00007f3f608ad59c in free () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f3f608a5d69 in _IO_free_backup_area ()
   from /lib/x86_64-linux-gnu/libc.so.6
#2  0x00007f3f608a52e5 in _IO_file_overflow ()
   from /lib/x86_64-linux-gnu/libc.so.6
#3  0x00007f3f608a4025 in _IO_file_xsputn ()
   from /lib/x86_64-linux-gnu/libc.so.6
#4  0x00007f3f60872aa1 in vfprintf () from /lib/x86_64-linux-gnu/libc.so.6
#5  0x00007f3f609330cb in __fprintf_chk () from /lib/x86_64-linux-gnu/libc.so.6
#6  0x00007f3f5ac10404 in ?? () from /usr/lib/libpq.so.5
#7  0x00007f3f5ac08257 in ?? () from /usr/lib/libpq.so.5
#8  0x00007f3f5ac0860e in PQfinish () from /usr/lib/libpq.so.5
#9  0x00007f3f573f4c4d in ?? () from /usr/lib/php5/20090626/pgsql.so
#10 0x00007f3f5da3ffde in ?? () from /usr/lib/apache2/modules/libphp5.so
#11 0x00007f3f5da3c81e in ?? () from /usr/lib/apache2/modules/libphp5.so
#12 0x00007f3f5da3e0a8 in zend_hash_graceful_reverse_destroy ()
   from /usr/lib/apache2/modules/libphp5.so
#13 0x00007f3f5da3032c in ?? () from /usr/lib/apache2/modules/libphp5.so
#14 0x00007f3f5d9dd030 in php_request_shutdown ()
   from /usr/lib/apache2/modules/libphp5.so
#15 0x00007f3f5dac0d67 in ?? () from /usr/lib/apache2/modules/libphp5.so
#16 0x00007f3f61705508 in ap_run_handler ()
#17 0x00007f3f6170597e in ap_invoke_handler ()
#18 0x00007f3f61715570 in ap_process_request ()
#19 0x00007f3f61712398 in ?? ()
#20 0x00007f3f6170bfa8 in ap_run_process_connection ()
#21 0x00007f3f6171a1d0 in ?? ()


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-06-05 13:38 UTC] mbeccati@php.net
-Status: Open +Status: Not a bug -PHP Version: 5.3.23 +PHP Version: 5.3.3
 [2013-06-05 13:38 UTC] mbeccati@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 15:01:31 2024 UTC