php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #64475 Update the version of internal SQLite sources in windows builds
Submitted: 2013-03-21 12:16 UTC Modified: 2014-03-27 09:45 UTC
Votes:16
Avg. Score:4.8 ± 0.4
Reproduced:12 of 12 (100.0%)
Same Version:7 (58.3%)
Same OS:9 (75.0%)
From: alejosimon at gmail dot com Assigned: ab (profile)
Status: Closed Package: PDO related
PHP Version: 5.5.0alpha5 OS:
Private report: No CVE-ID: None
 [2013-03-21 12:16 UTC] alejosimon at gmail dot com
Description:
------------
You can update the version of sqlite in this new version of PHP?

...because in unix systems use a global scope sqlite lib... but in windows systems 
depend only of the internal version from the php build, and still is 3.7.7.1 from 
php 5.4/5

... and php 5.5 should come with the new sqlite version, you think? :-)

... or remember the pdo_sqlite_external.dll ????? this was a good solution but 
died! :-(

Thanks!

Test script:
---------------
<?php

  $pdo = new PDO( 'sqlite::memory:' ) ;

  $res = $pdo->query( 'SELECT sqlite_version()' ) ;

  print_r( $res->fetchColumn() ) ;

?>

Expected result:
----------------
3.7.16

Actual result:
--------------
3.7.7.1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-05-02 07:08 UTC] pawlaktomek at gmail dot com
Please also update SQLite in all currently supported branches of PHP (e.g. 5.3 and 
5.4).

This is important to me, because SQLite 3.3.15+ far more effectively handles IN 
operator in WHERE clause, than it was in 
previous releases. Consequently change of SQLite engine version from 3.7.7.1 to 
3.3.15 causes queries in my application running 
3-5 times faster.
 [2013-05-02 07:22 UTC] pajoye@php.net
It has nothing to do with windows, sqlite is bundled in php sources and windows 
uses it for the sqlite related extension.
 [2013-05-02 07:22 UTC] pajoye@php.net
-Operating System: Windows 7 +Operating System:
 [2013-05-02 12:18 UTC] alejosimon at gmail dot com
Hi Pierre, I think that I already clarified, but I repeat again... I am only 
"user-programer" of PHP and not a "win-builder" versions, then I can not change 
and compile PHP every time under change the PHP version number, so you should 
update sqlite from sources before compiling... and I like many others who only 
use PHP and just download only the binaries for use, I was clear?! ;-)

Sorry but my english isn't buggy.

So Windows is not like Unix ... and does not use external sqlite lib, so we 
depend on the version that comes inside of the binaries.

Please I hope you can update it, who clearly appropriate.
Thanks.!
 [2013-05-02 13:39 UTC] pajoye@php.net
Distributions sometimes use system library, sometimes not. But php.net's sources 
bundled Sqlite and it is not Sqlite specific. See:

https://github.com/php/php-src/tree/master/ext/sqlite3/libsqlite

The day we will have the newer version there, windows will have it automatically 
as well.
 [2013-05-04 19:15 UTC] alejosimon at gmail dot com
OK, but who is in charge of updating this? that's just what it claims...

You might not yet have Windows versions that support an old version of sqlite 
for any reason.

It's just refresh the sources of this folder:

https://github.com/php/php-src/tree/master/ext/sqlite3/libsqlite

;-)
 [2013-05-10 17:07 UTC] alejosimon at gmail dot com
"sqlite is bundled in php sources"

So please tell me how and where should I ask for the update of sqlite.

Thank you.
 [2013-08-24 15:00 UTC] jasonlfunk at gmail dot com
I'm on OS X version 5.4 and agree that this should be upgraded. 3.7.7.1 is from 
over 2 years ago. I would like to use some features that exist in newer versions 
of the library such as named memory databases.
 [2014-03-08 22:47 UTC] alejosimon at gmail dot com
How to update the SQLite version bundled with PHP. (windows versions)

http://stackoverflow.com/questions/20327844/how-to-update-the-sqlite-version-bundled-with-php

PLEASE!!!!!!! give importance to this issue once and for all!!
 [2014-03-09 08:36 UTC] pajoye@php.net
-Assigned To: +Assigned To: ab
 [2014-03-09 08:36 UTC] pajoye@php.net
@a can you do in in 5.6 pls?
 [2014-03-09 12:11 UTC] ab@php.net
-Status: Assigned +Status: Closed
 [2014-03-09 12:11 UTC] ab@php.net
The bundled libsqlite was updated to 3.8.3.1 in PHP-5.6, ref 61db86bff34fff4174f80b4e9ff013a9c165b527
 [2014-03-09 14:07 UTC] alejosimon at gmail dot com
-Status: Closed +Status: Open
 [2014-03-09 14:07 UTC] alejosimon at gmail dot com
Thank you very much! it was time, now you just need to be responsible for compiling the Windows versions do also! THANKS!! I'm happy!
 [2014-03-10 10:46 UTC] ab@php.net
-Status: Open +Status: Closed
 [2014-03-10 10:46 UTC] ab@php.net
@alejosimon thanks for following, you can catch the updates in the latest snapshots. The next 5.6+ release should have it as well.
 [2014-03-10 14:44 UTC] alejosimon at gmail dot com
-Status: Closed +Status: Assigned
 [2014-03-10 14:44 UTC] alejosimon at gmail dot com
Thanks for the update .. now ... in future 5.5 versions can also upgrade this?
 [2014-03-11 08:15 UTC] ab@php.net
-Status: Assigned +Status: Closed
 [2014-03-11 08:15 UTC] ab@php.net
5.5 was also upgraded after all, you can catch the latest snapshots here http://windows.php.net/downloads/snaps/ 

Thanks.
 [2014-03-11 13:45 UTC] alejosimon at gmail dot com
-Status: Closed +Status: Assigned
 [2014-03-11 13:45 UTC] alejosimon at gmail dot com
THANKS! THANKS! THANKS! THANKS!

Knowing that it is as easy to upgrade ... do not know why I fought so almost 1 year or more. Why does this happen sometimes with people inside the core of PHP?
 [2014-03-11 14:54 UTC] ab@php.net
-Status: Assigned +Status: Closed
 [2014-03-11 14:54 UTC] ab@php.net
Not always that easy and not every upgrade is sensible right at some moment. But so much better it happens now :) Once you see some significant upgrade is possible, please don't hesitate to open yet another ticket.

Thanks.
 [2014-03-26 11:56 UTC] alejosimon at gmail dot com
-Status: Closed +Status: Assigned
 [2014-03-26 11:56 UTC] alejosimon at gmail dot com
Hello, sorry but... you can upgrade to the latest version again? because they found a bug concerning visual studio.

http://www.sqlite.org/releaselog/3_8_4_1.html

... If possible, for PHP 5.5 and 5.6 as above.

THANKS!!!!!!!!!!!!!!!!!!!!
 [2014-03-26 12:00 UTC] alejosimon at gmail dot com
I would like ... like to return the ext php_sqlite_external.dll which allowed me to download the version of sqlite.dll directly from the author and go! ;)
 [2014-03-26 12:02 UTC] alejosimon at gmail dot com
... sorry "php_pdo_sqlite_external.dll" is the correct name!
 [2014-03-26 12:08 UTC] alejosimon at gmail dot com
-Status: Assigned +Status: Open
 [2014-03-26 12:08 UTC] alejosimon at gmail dot com
for the RFC: 

As the ssh2 extension using ssh2.dll externally, you could do this with sqlite not? because it is something simple, and Windows users will depend strictly on the buils for these updates?. I have no power to propose a RFC, but for those who can!

they think?

Thanks and sorry!
 [2014-03-26 13:43 UTC] ab@php.net
-Status: Open +Status: Closed
 [2014-03-26 13:43 UTC] ab@php.net
Hi, thanks for reporting this. Actually i don't think this version is worth it to upgrade, the preprocessor bug mentioned in the changelog doesn't affect PHP build. You can find both PDO and sqlite3 extension DLLs in the builds.

Aside that, please do not reopen this ticket again and again but create another one. Having never ending tickets for all the issues is not a good practice. For your RFC suggestion, please use the mailing lists to discuss it.

Thanks.
 [2014-03-26 16:54 UTC] alejosimon at gmail dot com
-Summary: Update the version of internal SQLite lib in windows builds +Summary: Update the version of internal SQLite sources in windows builds -Status: Closed +Status: Assigned
 [2014-03-26 16:54 UTC] alejosimon at gmail dot com
YES! I'm do reopen this ticket ;) sorry sorry sorry but...

in the version 3.8.4 of sqlite they repair several some bugs and improves performance! please see 2014-03-10 (3.8.4) in http://www.sqlite.org/changes.html

thanks!
 [2014-03-27 09:45 UTC] ab@php.net
-Status: Assigned +Status: Closed
 [2014-03-27 09:45 UTC] ab@php.net
Please one issue per ticket. This issue is already closed and noted in the changelog. We can see then if this update can go into next beta. Thanks.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Mar 04 12:01:24 2021 UTC