php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64425 Problem with intval function
Submitted: 2013-03-14 09:17 UTC Modified: 2013-03-14 13:41 UTC
From: mszajner at rexoft dot pl Assigned:
Status: Not a bug Package: Variables related
PHP Version: 5.3.22 OS: Windows, Unix
Private report: No CVE-ID: None
 [2013-03-14 09:17 UTC] mszajner at rexoft dot pl
Description:
------------
I try to convert double to int, but result is sometimes wrong.

Test script:
---------------
echo intval(5 * 4.02 * 100), " == 2009 - WRONG!\n";
echo intval(round(5 * 4.02, 2) * 100), " == 2010 - OK!\n";


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-03-14 13:41 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2013-03-14 13:41 UTC] laruence@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

float are not accurate..
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Feb 26 15:01:29 2024 UTC