php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #64388 pdo_informix build as an extension on windows
Submitted: 2013-03-08 11:13 UTC Modified: 2014-03-03 19:04 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: edgardmessias at gmail dot com Assigned:
Status: Not a bug Package: PDO_INFORMIX (PECL)
PHP Version: 5.3.22 OS: Windows 7
Private report: No CVE-ID: None
 [2013-03-08 11:13 UTC] edgardmessias at gmail dot com
Description:
------------
Add this code in config.w32 be possible to compile as an extension:
CHECK_LIB("odbc32.lib", "pdo_odbc") && CHECK_LIB("odbccp32.lib", "pdo_odbc")

Test script:
---------------
Compile using phpize 
or
pecl install -f pdo_informix


Patches

Example (last revision 2013-03-08 11:13 UTC by edgardmessias at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-03-03 19:04 UTC] rahulpriyadarshi@php.net
-Status: Open +Status: Not a bug
 [2014-03-03 19:04 UTC] rahulpriyadarshi@php.net
PDO_INFORMIX has no dependency on PDO_ODBC, so there is no need to add pdo_odbc's check lib in config script.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 18:01:26 2019 UTC