php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64345 Please specify correct PostgreSQL installation path
Submitted: 2013-03-04 06:51 UTC Modified: 2013-03-04 06:55 UTC
From: americancafe at hotmail dot com Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 5.4.12 OS: OSX 10.6
Private report: No CVE-ID: None
 [2013-03-04 06:51 UTC] americancafe at hotmail dot com
Description:
------------
Now I have tried and tried. I already know what you're going to say "This is not a bug". Well it is to me and 100 other people who have posted this question onilne with no good response. >Cannot find libpq-fe.h< Well, I know exaclty where that library is. But, no one can tell me how to SPECIFY it to PHP. 


Test script:
---------------
./configure --with-pgsql=/usr            This does not work 
./configure --with-pgsql=/somePath       This does not work
./configure --with-pgsql='/somePath'     This does not work

Expected result:
----------------
I expect PHP to configure.


Actual result:
--------------
configure: error: Cannot find libpq-fe.h. Please specify correct PostgreSQL installation path

And how do I do that? Please stop assuming that everyone knows what you know.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-03-04 06:55 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2013-03-04 06:55 UTC] pajoye@php.net
You have to know how your platform works or where it installs files if you like 
to compile PHP yourself. On the other side, if you don't want to bother with 
that, use macports or other PHP packages for OS X.

If you still like to compile PHP, a simple google query will point you to many 
tutorials, f.e.:

http://drewish.com/content/2008/12/getting_php_gd_postgresql_working_on_osx_105_
aka_recompiling_everything
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 14:01:32 2024 UTC