php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64216 FILTER_VALIDATE_MAC constant unavailable
Submitted: 2013-02-15 12:40 UTC Modified: 2013-02-15 14:59 UTC
From: pear at laurent-laville dot org Assigned:
Status: Not a bug Package: Filter related
PHP Version: 5.5.0alpha4 OS: Windows
Private report: No CVE-ID: None
 [2013-02-15 12:40 UTC] pear at laurent-laville dot org
Description:
------------
While the FILTER_VALIDATE_MAC constant was implemented by this commit [1] since 
2012-12-24, PHP 5.5.0 alpha4 on windows platform does not provide it.
Almost one month after modification was applied.

See related request [2]


[1] https://github.com/php/php-src/commit/2f334438836f37b82d739b20a4d0f875278e4766

[2] https://bugs.php.net/bug.php?id=49180


PHP 5.5.0alpha4 (cli) (built: Jan 22 2013 21:25:00)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0-dev, Copyright (c) 1998-2013 Zend Technologies

Test script:
---------------
php -r "print_r(filter_list());"

Expected result:
----------------
Missing entry 

Array
(
    [ ] => validate_mac 
)



Actual result:
--------------
Array
(
    [0] => int
    [1] => boolean
    [2] => float
    [3] => validate_regexp
    [4] => validate_url
    [5] => validate_email
    [6] => validate_ip
    [7] => string
    [8] => stripped
    [9] => encoded
    [10] => special_chars
    [11] => full_special_chars
    [12] => unsafe_raw
    [13] => email
    [14] => url
    [15] => number_int
    [16] => number_float
    [17] => magic_quotes
    [18] => callback
)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-02-15 14:59 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2013-02-15 14:59 UTC] pajoye@php.net
This code has nothing to do with Windows, it is available on all platform.

The 5.5 branch has it in, so it will be in the next release. You can fetch a 
snapshot in the meantime, http://windows.php.net/downloads/snaps/php-5.5/

g:\php-sdk\php-master\vc11\x86\php-src>Release_TS\php  -r 
"print_r(filter_list());"
Array
(
    [0] => int
    [1] => boolean
    [2] => float
    [3] => validate_regexp
    [4] => validate_url
    [5] => validate_email
    [6] => validate_ip
    [7] => validate_mac
    [8] => string
    [9] => stripped
    [10] => encoded
    [11] => special_chars
    [12] => full_special_chars
    [13] => unsafe_raw
    [14] => email
    [15] => url
    [16] => number_int
    [17] => number_float
    [18] => magic_quotes
    [19] => callback
)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 05:05:53 2022 UTC