php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64128 buit-in web server is broken on ppc64
Submitted: 2013-02-01 18:06 UTC Modified: 2013-02-01 18:06 UTC
From: remi@php.net Assigned: remi
Status: Closed Package: Built-in web server
PHP Version: 5.4.11 OS: GNU/Linux
Private report: No CVE-ID:
 [2013-02-01 18:06 UTC] remi@php.net
Description:
------------
I think this bug also affects non x86 architecture

built-in server don't answer to any request.

Strace analysis show it enter an infinite loop of "select" but never accept any incoming connection. 

Source analysis show that fdset management using bit operator is broken.

Switching to standard FD_ISSET method fix the problem.

I have a patch ready to commit.



Test script:
---------------
This issue cause various test to fail:
< Bug #61977 Test exit code for various errors [sapi/cli/tests/bug43177.phpt]
< Bug #61679 (Error on non-standard HTTP methods) [sapi/cli/tests/bug61679.phpt]
< Bug #61977 test CLI web-server support for Mime Type File extensions mapping [sapi/cli/tests/bug61977.phpt]
< basic function [sapi/cli/tests/php_cli_server_001.phpt]
< $_SERVER variable [sapi/cli/tests/php_cli_server_002.phpt]
< Bug #55726 (Changing the working directory makes router script inaccessible) [sapi/cli/tests/php_cli_server_003.phpt]
< Bug #55747 (request headers missed in $_SERVER) [sapi/cli/tests/php_cli_server_004.phpt]
< Post a file [sapi/cli/tests/php_cli_server_005.phpt]
< Bug #55755 (SegFault when outputting header WWW-Authenticate) [sapi/cli/tests/php_cli_server_006.phpt]
< Bug #55758 (Digest Authenticate missed in 5.4) [sapi/cli/tests/php_cli_server_007.phpt]
< SERVER_PROTOCOL header availability [sapi/cli/tests/php_cli_server_008.phpt]
< PATH_INFO (relevant to #60112) [sapi/cli/tests/php_cli_server_009.phpt]
< Bug #60180 ($_SERVER["PHP_SELF"] incorrect) [sapi/cli/tests/php_cli_server_010.phpt]
< Bug #60180 ($_SERVER["PHP_SELF"] incorrect) [sapi/cli/tests/php_cli_server_011.phpt]
< Bug #60159 (Router returns false, but POST is not passed to requested resource) [sapi/cli/tests/php_cli_server_012.phpt]
< No router, no script [sapi/cli/tests/php_cli_server_013.phpt]
< Bug #60477: Segfault after two multipart/form-data POST requestes [sapi/cli/tests/php_cli_server_014.phpt]
< Bug #60523 (PHP Errors are not reported in browsers using built-in SAPI) [sapi/cli/tests/php_cli_server_015.phpt]
< Bug #60591 (Memory leak when access a non-exists file) [sapi/cli/tests/php_cli_server_016.phpt]
< Implement Req #60850 (Built in web server does not set $_SERVER['SCRIPT_FILENAME'] when using router) [sapi/cli/tests/php_cli_server_017.phpt]
< Implement Req #61679 (Support HTTP PATCH method) [sapi/cli/tests/php_cli_server_018.phpt]



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-02-01 18:06 UTC] remi@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: remi
 [2013-02-01 18:27 UTC] remi@php.net
Automatic comment on behalf of remi
Revision: http://git.php.net/?p=php-src.git;a=commit;h=0cea9e6843384c6c0ebb52047c42b0431a4f5660
Log: Fixed bug #64128 buit-in web server is broken on ppc64.
 [2013-02-01 18:27 UTC] remi@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 21:01:56 2014 UTC