php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64076 imap_sort() should to return FALSE on failure
Submitted: 2013-01-25 19:04 UTC Modified: 2020-10-12 16:30 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: Slim at inbox dot lv Assigned: cmb (profile)
Status: Closed Package: IMAP related
PHP Version: 5.3.21 OS:
Private report: No CVE-ID: None
 [2013-01-25 19:04 UTC] Slim at inbox dot lv
Description:
------------
imap_sort() accepts Search_criteria argument. When the value is unparsable, c-client  
returns error (it is accessible via imap_last_error()). In this case imap_sort() 
should to return false to flag the problem. 

Test script:
---------------
Run imap_sort() with any invalid search_criteria

Expected result:
----------------
False should be returned

Actual result:
--------------
Empty array is returned

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-12 16:30 UTC] cmb@php.net
-Status: Open +Status: Verified -Type: Feature/Change Request +Type: Bug -Assigned To: +Assigned To: cmb
 [2020-10-12 16:30 UTC] cmb@php.net
That looks like a real bug to me.
 [2020-10-13 15:18 UTC] cmb@php.net
The following pull request has been associated:

Patch Name: Fix #64076: imap_sort() does not return FALSE on failure
On GitHub:  https://github.com/php/php-src/pull/6332
Patch:      https://github.com/php/php-src/pull/6332.patch
 [2020-10-13 17:42 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=db8bf0a9e07f906ad5d771142e5873688aff8033
Log: Fix #64076: imap_sort() does not return FALSE on failure
 [2020-10-13 17:42 UTC] cmb@php.net
-Status: Verified +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 21 08:01:23 2020 UTC