php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64 what purify says.....
Submitted: 1998-02-12 12:32 UTC Modified: 1998-02-12 12:44 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: thies at digicol dot de Assigned:
Status: Closed Package: Other
PHP Version: 3.0b4 OS: solaris/hpux 10.x
Private report: No CVE-ID: None
 [1998-02-12 12:32 UTC] thies at digicol dot de
when i compile 3.0b4 (or the CVS version) using purify then i get the following problems on make test (btw make test says "all tests passed"):

(i don't want to annoy anybody but my expirience says that things should NOT come up with this kind of problems when purifie'd)

the following is from the 1st test (make test) there are sone more things that seem to appear later in the tests...

if somebody is interested into more "purified" stuff please contact me...

but - after all thanx for this cool php3!!!
tc

------
SBR: Stack array bounds read:
  * This is occurring while in:
	memcpy         [rtlib.o]
	hash_index_update_or_next_insert [hash.c:248]
	_register_list_destructors [internal_functions.c:474]
	php3_module_startup [main.c:978]
	main           [main.c:1313]
	_start         [crt1.o]
  * Reading 44 bytes from 0xeffff930.
  * Frame pointer 0xeffff948
  * Address 0xeffff930 is local variable "ld" in function _register_list_destructors.

this also happens on 
php3_minit_dir [dir.c:77]
php3_minit_file [file.c:194]
php3_minit_file [file.c:195]
php3_minit_db  [db.c:1083]
---------

another one is this:

FMR: Free memory read (10 times):
  * This is occurring while in:
	lex_scan       [language-scanner.lex:957]
	read_next_token [token_cache.c:132]
	phplex         [main.c:397]
	phpparse       [bison.simple:387]
	php3_parse     [main.c:1208]
	main           [main.c:1425]
  * Reading 4 bytes from 0x1b4858 in the heap.
  * Address 0x1b4858 is 40 bytes into a freed  block at 0x1b4830 of 48 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	_emalloc       [alloc.c:67]
	stack_push     [stack.c:53]
	eval_string    [language-scanner.lex:179]
	phpparse       [language-parser.y:273]
	php3_parse     [main.c:1208]
  * There have been 0 frees since this block was freed from:
	free           [rtlib.o]
	_efree         [alloc.c:119]
	stack_del_top  [stack.c:74]
	lex_scan       [language-scanner.lex:956]
	read_next_token [token_cache.c:132]
	phplex         [main.c:397]









Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-02-12 12:44 UTC] zeev
Fixed.  Patch:

--- internal_functions.c        Thu Feb 12 19:37:57 1998
+++ internal_functions-new.c    Thu Feb 12 19:37:32 1998
@@ -471,7 +471,7 @@
        ld.list_destructor=(void (*)(void *)) list_destructor;
        ld.plist_destructor=(void (*)(void *)) plist_destructor;
 
-       if (hash_next_index_insert(&GLOBAL(list_destructors),(void *) &ld,sizeof(GLOBAL(list_destructors)),NULL)==FAILURE) {
+       if (hash_next_index_insert(&GLOBAL(list_destructors),(void *) &ld,sizeof(list_destructors_entry),NULL)==FAILURE) {
                return FAILURE;
        }
        return GLOBAL(list_destructors).nNextFreeElement-1;

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 17:04:05 2021 UTC