php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63999 php with fpm fails to build on Solaris 10 or 11
Submitted: 2013-01-15 22:47 UTC Modified: 2013-01-16 02:27 UTC
From: yli at library dot tamu dot edu Assigned: aharvey
Status: Closed Package: Compile Failure
PHP Version: 5.4.10 OS: Solaris 10 or 11
Private report: No CVE-ID:
 [2013-01-15 22:47 UTC] yli at library dot tamu dot edu
Description:
------------
On Solaris 10 or Solaris 11 machine, configure with 

./configure --enable-fpm

build will fail with:

php-5.4.10/sapi/fpm/fpm/fpm_sockets.h:28: error: syntax error before numeric constant

Bug #62654 and Bug #63059 are referring to the same problem in earlier version (5.4.5, 5.4.6, 5.4.7). Both bugs are closed, yet the problem is still present in 5.4.10 release. So far, all versions of php 5.4.5 onwards fail to compile on Solaris 10 or 11 with fpm enable. 

Test script:
---------------
./configure --enable-fpm
make

Expected result:
----------------
Clean compile.

Actual result:
--------------
Doesn't compile. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-16 02:02 UTC] aharvey@php.net
Bug #63059 looks like it was closed by accident.

Unfortunately, the fix for bug #62654 didn't fix the header. I'll fix that up.
 [2013-01-16 02:02 UTC] aharvey@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: aharvey
 [2013-01-16 02:27 UTC] aharvey@php.net
-Status: Assigned +Status: Closed
 [2013-01-16 02:27 UTC] aharvey@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

This should be in PHP 5.3.22 and 5.4.12, barring something unexpected.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 06:02:27 2014 UTC