php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63971 Segfault when generating phar.php
Submitted: 2013-01-11 17:30 UTC Modified: 2013-02-18 00:36 UTC
From: olemarkus@php.net Assigned:
Status: No Feedback Package: PHAR related
PHP Version: 5.4.10 OS:
Private report: No CVE-ID:
Have you experienced this issue?
Rate the importance of this bug to you:

 [2013-01-11 17:30 UTC] olemarkus@php.net
Description:
------------
Several users report segfaults when building PHP with phar enabled

Build log:
https://tinderboxlogs.s3.amazonaws.com/tbamd64.excelsior.flameeyes.eu/dev-
lang%3Aphp-5.4.8%3A20121231-014433.html

Unfortunately, I have not been able to reproduce this issue, but it looks similar 
to closed bug 51216.

Downstream bug is https://bugs.gentoo.org/show_bug.cgi?id=451380




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-14 23:52 UTC] johannes@php.net
This typically happens when changing the PHP configuration between builds but not calling configure / make clean in between.
 [2013-01-14 23:52 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2013-01-15 10:19 UTC] olemarkus@php.net
Hi Johannes,

I doubt this is the case here. The Gentoo package system copies the entire 
source tree for each SAPI and starts from scratch in each one.

Also, this happens from the first SAPI compile. If you see the build log, you 
clearly see unpack -> configure -> make.

So I think this bug was closed a bit prematurely.
 [2013-01-15 10:19 UTC] olemarkus@php.net
-Status: Not a bug +Status: Open
 [2013-01-15 11:27 UTC] johannes@php.net
-Status: Open +Status: Feedback
 [2013-01-15 11:27 UTC] johannes@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

Well then maybe one of your patches is broken? You can also try running sapi/cli/php manually and try to have it segfault and provide a backtrace ...
 [2013-01-15 16:37 UTC] olemarkus@php.net
Thanks. I will see what information I can obtain.
 [2013-02-18 00:36 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 09:02:28 2014 UTC