php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63931 pecl install rrd problem
Submitted: 2013-01-07 11:46 UTC Modified: 2013-01-09 11:12 UTC
From: theronzorbas at yahoo dot com Assigned: koubel (profile)
Status: Closed Package: rrd (PECL)
PHP Version: 5.3 OS: OpenBSD 5.2
Private report: No CVE-ID: None
 [2013-01-07 11:46 UTC] theronzorbas at yahoo dot com
Description:
------------
#pecl install rrd command fails. Here is what i have. (I use what OpenBSD last 
stable release which is 5.2 presents...)

#uname -a
OpenBSD webserver.int.local 5.2 GENERIC i386

# pkg_info |grep pear
pear-1.9.4p1        base classes for common PHP tasks
pear-utils-1.9.4p1  utilities for managing pear extensions

# pkg_info |grep php
php-5.3.14p1        server-side HTML-embedded scripting language
php-gd-5.3.14p0     image manipulation extensions for php5
php-ldap-5.3.14p0   ldap protocol extensions for php5
php-mssql-5.3.14p0  microsoft sql access extensions for php5
php-mysql-5.3.14p0  mysql database access extensions for php5
php-snmp-5.3.14p0   snmp protocol extensions for php5

# pkg_info |grep php
php-5.3.14p1        server-side HTML-embedded scripting language
php-gd-5.3.14p0     image manipulation extensions for php5
php-ldap-5.3.14p0   ldap protocol extensions for php5
php-mssql-5.3.14p0  microsoft sql access extensions for php5
php-mysql-5.3.14p0  mysql database access extensions for php5
php-snmp-5.3.14p0   snmp protocol extensions for php5

# pkg_info |grep rrd
rrdtool-1.2.30p3    system to store and display time-series data

# pkg_info -L rrdtool-1.2.30p3 |grep lib
/usr/local/lib/librrd.a
/usr/local/lib/librrd.la
/usr/local/lib/librrd.so.3.0
/usr/local/lib/librrd_th.a
/usr/local/lib/librrd_th.la
/usr/local/lib/librrd_th.so.3.0


Test script:
---------------
# pecl install rrd
downloading rrd-1.1.0.tgz ...
Starting to download rrd-1.1.0.tgz (18,639 bytes)
......done: 18,639 bytes
11 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
building in /tmp/pear/temp/pear-build-root0hxK7UvUxX/rrd-1.1.0
running: /tmp/pear/temp/rrd/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... yes
checking build system type... i386-unknown-openbsd5.2
checking host system type... i386-unknown-openbsd5.2
checking target system type... i386-unknown-openbsd5.2
checking for PHP prefix... /var/www/pear
checking for PHP includes... -I/usr/local/share/php-5.3/include -I/usr/local/share/php-5.3/include/main -I/usr/local/share/php-5.3/include/TSRM -I/usr/local/share/php-5.3/include/Zend -I/usr/local/share/php-5.3/include/ext -I/usr/local/share/php-5.3/include/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php-5.3/modules
checking for PHP installed headers prefix... /usr/local/share/php-5.3/include
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... gawk
checking for rrdtool support... yes, shared
checking for rrdtool... /usr/local/bin/rrdtool
checking for rrdtool header files in default paths... found in /usr/local/include
checking for rrd_create in -lrrd... no
configure: error: wrong rrd lib version or lib not found
ERROR: `/tmp/pear/temp/rrd/configure' failed

Expected result:
----------------
Pecl rrd should be installed

Actual result:
--------------
Configure fails.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-07 14:02 UTC] koubel@php.net
-Status: Open +Status: Feedback -PHP Version: Irrelevant +PHP Version: 5.3
 [2013-01-07 14:02 UTC] koubel@php.net
It seems that something failed when compilation of rrd_create() test occurred. Content of config.log for detail analysis is mandatory. 

Try to install the extension via phpize - http://php.net/manual/en/install.pecl.phpize.php, and add or make config.log readable through some url please, config.log is the result of ./configure command
 [2013-01-07 14:23 UTC] theronzorbas at yahoo dot com
-Status: Feedback +Status: Open
 [2013-01-07 14:23 UTC] theronzorbas at yahoo dot com
What i did:
http://pastebin.com/vPZq2q06

Here is confi.log file contents
http://pastebin.com/1wpaEgNn
 [2013-01-07 16:21 UTC] koubel@php.net
-Status: Open +Status: Verified -Assigned To: +Assigned To: koubel
 [2013-01-07 16:21 UTC] koubel@php.net
this is cause of error:

(line 247 of config.log)

/usr/bin/ld: warning: libfreetype.so.18.3, needed by /usr/local/lib/librrd.so.3.0, not found (try using -rpath or -rpath-link)

/usr/local/lib/librrd.so.3.0: undefined reference to `FT_Init_FreeType
...

It seems that librrd isn't correctly installed or some special tweak for calling the compiler/linker on your OS is needed. I don't any experience with Free/OpenBSD. Sorry, maybe try to consult with someone with C, shared libraries and autotools knowledge on FreeBSD. I try to find someone topics on the Internet.
 [2013-01-07 21:46 UTC] theronzorbas at yahoo dot com
This may help you:
ldconfig -r |grep libfreetype.so
        60:-lfreetype.18.3 => /usr/X11R6/lib/libfreetype.so.18.3

# ldconfig -r |grep librrd.so
        164:-lrrd.3.0 => /usr/local/lib/librrd.so.3.0

# ls -l /usr/local/lib/librrd.so.3.0
-rw-r--r--  1 root  bin  309851 Aug  4 01:49 /usr/local/lib/librrd.so.3.0

# ls -l /usr/X11R6/lib/libfreetype.so.18.3
-r--r--r--  1 root  bin  543118 Jul 23 07:53 /usr/X11R6/lib/libfreetype.so.18.3

# uname -prs
OpenBSD 5.2 i386
 [2013-01-08 08:54 UTC] koubel@php.net
-Status: Verified +Status: Feedback
 [2013-01-08 08:54 UTC] koubel@php.net
So, I'm still thinking that problem is with your installation of rrd devel library. Try to follow my advices from previous comment. 

There were also some users with your OS without this problem, you can try to contact them for more information to solve your problem - see https://bugs.php.net/bug.php?id=59729 for contacts.
 [2013-01-08 18:07 UTC] theronzorbas at yahoo dot com
I have not compiled rrdtool from source. I've just installed rrdtool from 
official OpenBSD ports tree. Also i have tried steps written at bug 59729 but 
had no solution.
Also bug 59729 is about FreeBSD. My OS is OpenBSD. They have different styles...

Anyway, as i see OpenBSD ports are too old and there is no way to upgrade to 
current rrdtool till some OpenBSD developer upgrade base perl on OpenBSD. (An 
OpenBSD developer said that.)

So, you may close this bug request cause it is insolvable for now.
Thanks for your time...
 [2013-01-08 18:07 UTC] theronzorbas at yahoo dot com
-Status: Feedback +Status: Assigned
 [2013-01-09 11:12 UTC] koubel@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jun 16 17:01:30 2019 UTC