php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63925 $http_response_header unavailable in command line
Submitted: 2013-01-07 05:23 UTC Modified: 2013-01-07 05:29 UTC
From: litesoftwares at gmail dot com Assigned:
Status: Not a bug Package: Variables related
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
 [2013-01-07 05:23 UTC] litesoftwares at gmail dot com
Description:
------------
The given test script does not work in command line mode.
---
From manual page: 
http://www.php.net/reserved.variables.httpresponseheader#refsect1-
reserved.variables.httpresponseheader-description
---


Test script:
---------------
function get_contents() {
  file_get_contents("http://example.com");
  var_dump($http_response_header);
}



Expected result:
----------------
array(9) {
  [0]=>
  string(15) "HTTP/1.1 200 OK"
  [1]=>
  string(35) "Date: Sat, 12 Apr 2008 17:30:38 GMT"
  [2]=>
  string(29) "Server: Apache/2.2.3 (CentOS)"
  [3]=>
  string(44) "Last-Modified: Tue, 15 Nov 2005 13:24:10 GMT"
  [4]=>
  string(27) "ETag: "280100-1b6-80bfd280""
  [5]=>
  string(20) "Accept-Ranges: bytes"
  [6]=>
  string(19) "Content-Length: 438"
  [7]=>
  string(17) "Connection: close"
  [8]=>
  string(38) "Content-Type: text/html; charset=UTF-8"
}

Actual result:
--------------
NULL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-07 05:29 UTC] litesoftwares at gmail dot com
Mistake report
 [2013-01-07 05:29 UTC] litesoftwares at gmail dot com
-Status: Open +Status: Closed
 [2013-01-07 05:29 UTC] rasmus@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Apr 12 21:01:30 2024 UTC