php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63887 The Failover doesnot work
Submitted: 2013-01-02 20:23 UTC Modified: 2021-06-09 11:52 UTC
Votes:3
Avg. Score:3.7 ± 0.9
Reproduced:2 of 3 (66.7%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: saurabh dot tiwari22 at gmail dot com Assigned: cmb (profile)
Status: Closed Package: memcached (PECL)
PHP Version: 5.3.20 OS: Ubuntu
Private report: No CVE-ID: None
 [2013-01-02 20:23 UTC] saurabh dot tiwari22 at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/memcached.constants
---
I am trying to use the auto failover for memcached and I keep getting Server is 
Marked Dead. Below are the options I am using.

         Memcached::OPT_DISTRIBUTION =>  Memcached::DISTRIBUTION_CONSISTENT,
         Memcached::OPT_LIBKETAMA_COMPATIBLE => TRUE,
         Memcached::OPT_CONNECT_TIMEOUT => 50,
         Memcached::OPT_SEND_TIMEOUT => 5000,
         Memcached::OPT_RECV_TIMEOUT => 5000,
         Memcached::OPT_POLL_TIMEOUT => 100,
         Memcached::OPT_SERVER_FAILURE_LIMIT => 10,
         Memcached::OPT_REMOVE_FAILED_SERVERS => TRUE,
         Memcached::OPT_RETRY_TIMEOUT => 10,
         Memcached::OPT_AUTO_EJECT_HOSTS => TRUE


Expected result:
----------------
Since I am using consistent hashing Memcached should start mapping keys to a 
different server.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-09 11:52 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2021-06-09 11:52 UTC] cmb@php.net
The memcached bug tracker is now on Github[1].  If this is still
an issue with the current memcached version, please report there.

[1] <https://github.com/php-memcached-dev/php-memcached/issues>
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 28 00:01:32 2024 UTC