php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #63851 inet_ntop in WS2_32.dll has Windows Vista / Windows Server 2008 minimum require
Submitted: 2012-12-25 13:09 UTC Modified: 2013-01-08 05:50 UTC
Votes:6
Avg. Score:4.5 ± 0.8
Reproduced:5 of 6 (83.3%)
Same Version:5 (100.0%)
Same OS:5 (100.0%)
From: hanskrentel at yahoo dot de Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.5.0alpha2 OS: Win32 / XP
Private report: No CVE-ID: None
 [2012-12-25 13:09 UTC] hanskrentel at yahoo dot de
Description:
------------
I know that you don't want to support Windows XP any longer, but I think it's a 
pitty.

When asked about that one only got the answer back that "things must not break 
immediatly".

My first reaction should have been "dream on" because as I now found out just 
starting on XP does fail immediately:

inet_ntop entry point can not be found in WS2_32.dll - It has Windows Vista / 
Windows Server 2008 minimum requirements

Please see http://social.msdn.microsoft.com/Forums/en-
US/vcgeneral/thread/e40465f2-41b7-4243-ad33-15ae9366f4e6 on how to make that 
compatible, it might be of use.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-08 03:28 UTC] aharvey@php.net
I think it's extremely unlikely dropping XP and 2003 support will be revisited at this point.
 [2013-01-08 03:28 UTC] aharvey@php.net
-Status: Open +Status: Not a bug -Package: Win32API related +Package: Windows Installer
 [2013-01-08 05:50 UTC] pajoye@php.net
@hanskrentel at yahoo dot de

XP is dead already from a MSFT point of view, no update and so on.

If you still have to use these versions (xp, 2003 and the likes), you can stick to 
5.3 or 5.4 (which will be around for the next two years). If you have to support 
XP in two years, you will have other issues to deal with than php :).
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Aug 17 22:01:26 2019 UTC