php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63805 Problem during compiling php-gtk with php 5.4
Submitted: 2012-12-19 11:15 UTC Modified: 2012-12-19 15:37 UTC
From: marco_mg at libero dot it Assigned:
Status: Not a bug Package: PHP-GTK related
PHP Version: 5.4Git-2012-12-19 (Git) OS: GNU/Linux (Debian Wheezy)
Private report: No CVE-ID: None
 [2012-12-19 11:15 UTC] marco_mg at libero dot it
Description:
------------
While compiling php-gtk stops with an error.

Test script:
---------------
marco@ACER:~/Scrivania/php-gtk-2.0.1$ make
/bin/bash /home/marco/Scrivania/php-gtk-2.0.1/libtool --mode=compile cc  -I./ext/gtk+/ -I/home/marco/Scrivania/php-gtk-2.0.1/./ext/gtk+/ -DPHP_ATOM_INC -I/home/marco/Scrivania/php-gtk-2.0.1/include -I/home/marco/Scrivania/php-gtk-2.0.1/main -I/home/marco/Scrivania/php-gtk-2.0.1 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/libglade-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include  -DHAVE_CONFIG_H  -g -O2   -c /home/marco/Scrivania/php-gtk-2.0.1/./ext/gtk+/php_gtk+.c -o ./ext/gtk+/php_gtk+.lo 
libtool: compile:  cc -I./ext/gtk+/ -I/home/marco/Scrivania/php-gtk-2.0.1/./ext/gtk+/ -DPHP_ATOM_INC -I/home/marco/Scrivania/php-gtk-2.0.1/include -I/home/marco/Scrivania/php-gtk-2.0.1/main -I/home/marco/Scrivania/php-gtk-2.0.1 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/libglade-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -DHAVE_CONFIG_H -g -O2 -c /home/marco/Scrivania/php-gtk-2.0.1/./ext/gtk+/php_gtk+.c  -fPIC -DPIC -o ./ext/gtk+/.libs/php_gtk+.o
In file included from /home/marco/Scrivania/php-gtk-2.0.1/./ext/gtk+/php_gtk+.c:23:0:
/home/marco/Scrivania/php-gtk-2.0.1/main/php_gtk.h:307:75: error: unknown type name 'function_entry'
In file included from /home/marco/Scrivania/php-gtk-2.0.1/./ext/gtk+/php_gtk+.c:23:0:
/home/marco/Scrivania/php-gtk-2.0.1/main/php_gtk.h:308:79: error: unknown type name 'function_entry'
/home/marco/Scrivania/php-gtk-2.0.1/main/php_gtk.h:490:75: error: unknown type name 'function_entry'
/home/marco/Scrivania/php-gtk-2.0.1/main/php_gtk.h:506:77: error: unknown type name 'function_entry'
make: *** [ext/gtk+/php_gtk+.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-12-19 14:24 UTC] auroraeosrose@php.net
-Status: Open +Status: Feedback
 [2012-12-19 14:24 UTC] auroraeosrose@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

I cannot reproduce this, master branch of git compiles fine against PHP 5.4

You used the source code from https://github.com/php/php-gtk-src.git correct?  And you checked out the master branch

php-gtk 2.0.1 does NOT work with PHP 5.4 nor will it

The compile error displayed says you're using php-gtk-2.0.1 source
 [2012-12-19 15:27 UTC] marco__mg at libero dot it
I have downloaded the sources from http://gtk.php.net/download.php (php-gtk 2.0.1).
 [2012-12-19 15:32 UTC] marco__mg at libero dot it
Now I've cloned git repository and it works!
Thank you very much!
 [2012-12-19 15:37 UTC] auroraeosrose@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2012-12-19 15:37 UTC] auroraeosrose@php.net
-Status: Feedback +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 17 21:01:24 2020 UTC