php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63803 Php Warning: Socket_Read(): Unable To Read From Socket [104]
Submitted: 2012-12-19 09:20 UTC Modified: 2012-12-20 01:07 UTC
From: tuan at sarasavi dot lk Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 5.3.19 OS: Ubuntu
Private report: No CVE-ID: None
 [2012-12-19 09:20 UTC] tuan at sarasavi dot lk
Description:
------------
This script working fine, but after couple of hours I have got some errors

Test script:
---------------
<?php
ini_set('error_reporting', E_ALL ^ E_NOTICE);
ini_set('display_errors', 1);
require_once '../includes/session.php';
require_once '../includes/connection.php';
require_once '../classes/logfile.php';
require_once '../classes/Tracker.php';
?>
<?php



$address = '192.168.1.225'; // IP Address
$port=9000; //Port


$sock = socket_create(AF_INET, SOCK_STREAM, getprotobyname('tcp'));
socket_bind($sock, $address, $port) or die ("cannot bind to address.");
echo socket_strerror(socket_last_error());
socket_listen($sock,20);
$i=0;
while(1){
$result = $client[++$i] = socket_accept($sock);
$input = socket_read($client[$i], 1024000);


if($result):
$data = 'Thank you for your request!' . " \r\n";
socket_write($client[$i], $data, 1024000);
endif;


socket_write($client[$i], $input , 1024000);

$finInput = $input;

echo $finInput . "\r\n";

$lf = new Logfile();
$lf->write($finInput);

$tracker = new Tracker();

$data_array = $tracker->splitdata($finInput);
$location = $tracker->getlatlng($data_array[5], $data_array[7]);

$newloc = array();

$newloc['lat'] = $location['lat'];
$newloc['lng'] = $location['lng'];
$newloc['imei'] = $data_array[16];
$newloc['signal'] = $data_array[15];
$newloc['speed'] = $data_array[9];
$tracker->addlocation($newloc);
echo "\r\n";
print_r($newloc);

socket_close($client[$i]);
}
socket_close($sock);
?>

Actual result:
--------------
PHP Warning:  socket_read(): unable to read from socket [104]: Connection reset 
by 
peer in /var/www/gpssys/bin/deamon_test.php on line 41

Warning: socket_read(): unable to read from socket [104]: Connection reset by 
peer 
in /var/www/gpssys/bin/deamon_test.php on line 41
PHP Warning:  socket_write(): unable to write to socket [32]: Broken pipe in 
/var/www/gpssys/bin/deamon_test.php on line 45

Warning: socket_write(): unable to write to socket [32]: Broken pipe in 
/var/www/gpssys/bin/deamon_test.php on line 45
PHP Warning:  socket_write(): unable to write to socket [32]: Broken pipe in 
/var/www/gpssys/bin/deamon_test.php on line 51

Warning: socket_write(): unable to write to socket [32]: Broken pipe in 
/var/www/gpssys/bin/deamon_test.php on line 51

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-12-20 01:07 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2012-12-20 01:07 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This looks like an issue with your network or server, rather than PHP itself.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 25 04:03:37 2022 UTC