php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6373 I had an error running make (compiling)
Submitted: 2000-08-27 05:03 UTC Modified: 2000-08-31 16:42 UTC
From: raulgd at ver dot megared dot net dot mx Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.0.1pl2 OS: Yellow Dog Linux (linuxppc)
Private report: No CVE-ID: None
 [2000-08-27 05:03 UTC] raulgd at ver dot megared dot net dot mx
---HERE I RAN THE MAKE ----
[root@localhost php-4.0.1pl2]# make
--- STARTED ----
Making all in Zend
make[1]: Entering directory `/temp/php-4.0.1pl2/Zend'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/temp/php-4.0.1pl2/Zend'
Making all in main
make[1]: Entering directory `/temp/php-4.0.1pl2/main'
make[2]: Entering directory `/temp/php-4.0.1pl2/main'
gcc -DHAVE_CONFIG_H -I. -I/temp/php-4.0.1pl2/main -I/temp/php-4.0.1pl2 -I/temp/php-4.0.1pl2/ma
in -I/temp/apache_1.3.12/src/include -I/temp/apache_1.3.12/src/os/unix -I/temp/php-4.0.1pl2/Ze
nd -I/temp/php-4.0.1pl2 -I/usr/local/mysql/include/mysql -I/temp/php-4.0.1pl2/ext/xml/expat/xm
ltok -I/temp/php-4.0.1pl2/ext/xml/expat/xmlparse  -DXML_BYTE_ORDER=21 -g -O2  -c main.c && tou
ch main.lo
main.c: In function `php_error_cb':
main.c:370: incompatible types in assignment
main.c:435: incompatible types in assignment
make[2]: *** [main.lo] Error 1
make[2]: Leaving directory `/temp/php-4.0.1pl2/main'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/temp/php-4.0.1pl2/main'
make: *** [all-recursive] Error 1
--- HERE ENDS WITH ERROR ---
[root@localhost php-4.0.1pl2]# 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-29 09:47 UTC] sniper@php.net
Please attach your configure line here.

--Jani
 [2000-08-30 05:05 UTC] sniper@php.net
User feedback:
--------------

I compiled it with red hat linux on a PC and it worked this
configure, but it's not working with the ppc, the line is:

./configure --with-mysql=/usr/local/mysql \
--with-xml \
--with-apache=../apache_1.3.12 \
--enable-track-vars

I installed before mysql and configuring apache.... I did
the exact same thing with the exact same commands and it
worked on PC but it didn't in ppc, everything could be made
except the PHP, so that's why I thought it's a bug.

----

Please try php4.0.2 so that we can be sure this problem
still exists and report back (using this bug form) if it
works or not.
 
--Jani
 [2000-08-31 16:42 UTC] jmoore@php.net
Feedback from user:

Hi!
it finally worked!!! tks a lot!!! now we can all say that it also
compiles well in linux for PPC...
the 4.0.2 works very well!!! you guys rock!!! you really are
programmers...
well, glad you could help me... if you can give me some adresses where I
can download libs (like the .dll's for windows) for the linux I would
really appreciate it, tks again!!!


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Feb 07 06:05:51 2023 UTC