php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #63727 No function to access last opened connection link
Submitted: 2012-12-08 12:02 UTC Modified: 2012-12-10 01:51 UTC
From: oladoke at yahoo dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: Irrelevant OS: Snow Leopard
Private report: No CVE-ID: None
 [2012-12-08 12:02 UTC] oladoke at yahoo dot com
Description:
------------
---
From manual page: http://www.php.net/function.mysqli-connect#refsect1-
function.mysqli-connect-description
---
mySQL class automatically retrieved current connection link

There is not function to retrieve current connection link in mySQLi class. This 
would be very useful and would make the migration from mysql to mysqli much 
easier. mysqli_init() only returns an object with no thread id



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-12-10 01:51 UTC] aharvey@php.net
The mysqli object is the "connection link" when using the mysqli API.

By design → closing not a bug.
 [2012-12-10 01:51 UTC] aharvey@php.net
-Status: Open +Status: Not a bug -Package: Output Control +Package: MySQLi related
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 29 03:03:49 2022 UTC