php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63720 Wincache sometimes fail to initialize session if basic auth enabled
Submitted: 2012-12-07 14:01 UTC Modified: 2017-06-05 20:15 UTC
Votes:8
Avg. Score:4.5 ± 0.7
Reproduced:8 of 8 (100.0%)
Same Version:3 (37.5%)
Same OS:5 (62.5%)
From: info at atifans dot net Assigned: ericsten (profile)
Status: Closed Package: WinCache (PECL)
PHP Version: 5.4.9 OS: Windows Server 2008 R2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: info at atifans dot net
New email:
PHP Version: OS:

Further comment on this bug is unnecessary.

 

 [2012-12-07 14:01 UTC] info at atifans dot net
Description:
------------
The environment is PHP official-compiled VC9 5.4.9 NTS running on IIS 7.5 using 
FastCGI, and Wincache 1.3.4.1 is selected to be the session handler.
When access PHPMyAdmin with IIS basic authentication enabled, wincache will 
sometimes fail to initialize the session after logged in PMA.

Test script:
---------------
phpMyAdmin\libraries\session.inc.php 

Expected result:
----------------
HTTP 200 OK

Actual result:
--------------
HTTP 500 with the following logged error message.
session_start(): Failed to initialize storage module: wincache

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-02-20 16:28 UTC] ericsten@php.net
-Assigned To: +Assigned To: ericsten
 [2017-06-05 20:15 UTC] ericsten@php.net
-Status: Assigned +Status: Closed -Block user comment: No +Block user comment: Yes
 [2017-06-05 20:15 UTC] ericsten@php.net
Unable to reproduce on current builds.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Oct 16 04:01:26 2019 UTC