php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63524 Fails to compile with php 5.4.6
Submitted: 2012-11-15 08:42 UTC Modified: 2012-12-13 00:52 UTC
From: gaby_64 at live dot ca Assigned:
Status: Not a bug Package: xdiff (PECL)
PHP Version: Irrelevant OS: Ubuntu
Private report: No CVE-ID: None
 [2012-11-15 08:42 UTC] gaby_64 at live dot ca
Description:
------------
xdiff.c:39:5: error: duplicate 'static'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-12-13 00:52 UTC] felipe@php.net
This has been fixed months ago. Try the latest version of the extension.
 [2012-12-13 00:52 UTC] felipe@php.net
-Status: Open +Status: Not a bug
 [2013-02-22 22:23 UTC] mike at barking dot ca
I had the same error message with the latest version of xdiff on PECL (1.5.2, 2012-06-11), but I'm running PHP 5.3.10.

Doing a "pecl install xdiff-1.5.1.tgz" (1.5.2, 2009-10-18, downloaded from http://pecl.php.net/package/xdiff ) solved the issue for me, so perhaps might help others too...
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 15 05:01:41 2019 UTC