php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #63479 Support different locking on FreeBSD
Submitted: 2012-11-10 06:27 UTC Modified: 2012-11-10 06:48 UTC
From: 2ge at 2ge dot us Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 5.4.8 OS: FreeBSD 8.2
Private report: No CVE-ID: None
 [2012-11-10 06:27 UTC] 2ge at 2ge dot us
Description:
------------
Hi,

using APC 3.1.13, FreeBSD 8.2, I got "Locking type: File Locks", which I believe 
is not optimal as "Locking type: pthread mutex" in Linux systems.

Further reading:
http://www.ioremap.net/node/216/
http://www.unix.com/man-page/FreeBSD/9/locking/


Expected result:
----------------
support different locking mechanism



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-10 06:48 UTC] rasmus@php.net
You can try using --enable-apc-spinlocks
 [2012-11-10 06:48 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2012-11-10 16:42 UTC] 2ge at 2ge dot us
after recompiling I got spin Locks locking, which should be better I guess. Thanks 
for info.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 23 15:01:24 2021 UTC