php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63467 is_callable returns false for public function inherited from parent
Submitted: 2012-11-08 12:53 UTC Modified: 2012-11-08 16:13 UTC
From: martijn dot otto at copernica dot com Assigned:
Status: Not a bug Package: Class/Object related
PHP Version: Irrelevant OS: linux
Private report: No CVE-ID: None
 [2012-11-08 12:53 UTC] martijn dot otto at copernica dot com
Description:
------------
When calling is_callible on a public function inherited from a parent, it will 
return false.

Test script:
---------------
class a
{
    public function bla() {}
}

class b extends a
{
}

$b = new b;
var_dump(is_callable($b, 'bla'));


Expected result:
----------------
bool(true)

Actual result:
--------------
bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-08 16:13 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2012-11-08 16:13 UTC] laruence@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

should be:is_callable(array($b, 'bla'));
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Mar 01 22:01:28 2024 UTC