php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63452 PDO::PARAM_LOB does not bind to a stream for fetching a BLOB
Submitted: 2012-11-07 09:42 UTC Modified: 2012-11-07 12:16 UTC
From: vicrry at yahoo dot com dot hk Assigned:
Status: Not a bug Package: PDO related
PHP Version: 5.4.8 OS: CentOS
Private report: No CVE-ID: None
 [2012-11-07 09:42 UTC] vicrry at yahoo dot com dot hk
Description:
------------
This is similar to the closed bug #40913, but I have a different OS and a newer 
PHP version.

It still exists in PHP 5.4.8.

I am relatively new to the bug system, if this is considered a duplicate, please 
close this and reopen #40913.

Test script:
---------------
$stmt = $pdo->prepare('SELECT blobfield FROM filetable');

$rset = $stmt->execute();

$rset->bindColumn(1, $blob, PDO::PARAM_LOB);

$rset->fetch(PDO::FETCH_BOUND);

echo gettype($blob);

Expected result:
----------------
resource

Actual result:
--------------
string

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-07 12:16 UTC] johannes@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

#40913 was reopened
 [2012-11-07 12:16 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 16:01:29 2024 UTC