php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #63401 patch for access non-ANSI files/directories
Submitted: 2012-10-30 21:57 UTC Modified: 2013-04-23 16:24 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: j4f at bk dot ru Assigned:
Status: Duplicate Package: *Directory/Filesystem functions
PHP Version: 5.4.8 OS: windows
Private report: No CVE-ID: None
 [2012-10-30 21:57 UTC] j4f at bk dot ru
Description:
------------
Windows version of PHP have an very old bug, that not allowing to open files (directories) that contains UNICODE symbols. It's because it use ANSI functions to operate with filesystem. I analyze problem, and propose next solution: take UTF-8 PHP strings, convert them in code to wchar_t, and use windows UNICODE functions for access filesystem.
My patch demonstrates fully functional workaround. But it is not well integrated nor optimized.
Please, analyze and integrate this solution into mainline codebase, because it a very demanded feature.
Best regards, Yury Presnyakov.

Expected result:
----------------
This patch transparently converts UTF-8 strings to UNICODE strings (and back, if needed). That made possible to access in windows files that contains non ANSI characters.


Patches

add-win-fs-unicode-support (last revision 2012-10-30 22:09 UTC) by j4f at bk dot ru)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-04-23 16:24 UTC] pajoye@php.net
-Status: Open +Status: Duplicate
 [2013-04-23 16:24 UTC] pajoye@php.net
Thanks for your patch!

Sadly it is only a very small part of what has to be done to support Unicode 
filepaths.

I mark this bug as duplicate as there is already an open issue/feature request 
about it. More details about unicode for windows file operations will be added in 
the wiki, most likely for php-next.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sat Sep 22 08:01:25 2018 UTC