php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63400 Multi_Curl does not work, single curl does
Submitted: 2012-10-30 15:36 UTC Modified: 2012-10-31 21:47 UTC
From: contact at wimbledon-it dot co dot uk Assigned:
Status: Not a bug Package: cURL related
PHP Version: 5.4.8 OS: Windows 7 64
Private report: No CVE-ID: None
 [2012-10-30 15:36 UTC] contact at wimbledon-it dot co dot uk
Description:
------------
The code provided runs on 5.3.6 perfectly and returns the google.co.uk and 
reddit.com source code. 

The curl version provided is 7.24 - that a version from January 2012. There is 
already 7.28 available. It has not been tested with another version then the one 
that is provided by PHP.


Test script:
---------------
http://pastebin.com/7S5ScDYJ

Expected result:
----------------
Should be able to see the Google and Reddit website.

Actual result:
--------------
it exceeds the execution time OR 
Warning: (null)(): 10 is not a valid cURL handle resource in Unknown on line 0 
OR 
Warning: (null)(): 65 is not a valid cURL handle resource in Unknown on line 0


The same happens in 5.3.18


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-31 21:47 UTC] pierrick@php.net
-Status: Open +Status: Not a bug
 [2012-10-31 21:47 UTC] pierrick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Same as #61141
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 22:01:29 2019 UTC