php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63378 xmlreader libxml2 2.9.0 undefined symbol: xmlTextReaderSetup
Submitted: 2012-10-28 21:29 UTC Modified: 2013-02-22 00:17 UTC
From: spamik at yum dot pl Assigned:
Status: Not a bug Package: XML Reader
PHP Version: 5.4.8 OS:
Private report: No CVE-ID: None
 [2012-10-28 21:29 UTC] spamik at yum dot pl
Description:
------------
<?php
$xml = new XMLReader();
$xmldata = '<TestOne><tag>data</tag><tag>data</tag></TestOne>';
$xml->XML($xmldata);
?>

php 5.4.8 compiled with libxml2 2.9.0

/usr/bin/php: symbol lookup error: /usr/bin/php: undefined symbol: 
xmlTextReaderSetup

It works when php is compiled against libxml2 2.6.26


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-29 15:25 UTC] felipe@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Not a PHP problem. Try a clean PHP build on your system again.
 [2012-10-29 15:25 UTC] felipe@php.net
-Status: Open +Status: Not a bug
 [2013-02-20 23:58 UTC] spamik at yum dot pl
Not an answer. Not related to the question. Yes a bug in libxml extension which is 
not compatibile with new libxml2 libs.
 [2013-02-21 12:36 UTC] pajoye@php.net
@spamik at yum dot pl

What Felipe said is correct. It builds just fine using 2.9.0 (be unix or windows).

Try again using a clean build (read: either download 5.4.x again or do a 
buildconf, configure, etc.).
 [2013-02-22 00:17 UTC] spamik at yum dot pl
I never said it does not build! 
/usr/bin/php: undefined symbol: xmlTextReaderSetup
is obviosly runtime crash not a build problem (which does not happen when build 
against very old libxml2 2.6.26)
I always do clean build.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 06:01:23 2020 UTC