php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63349 Segfault during GC
Submitted: 2012-10-24 20:48 UTC Modified: 2012-10-25 07:06 UTC
From: phpwnd at gmail dot com Assigned:
Status: Closed Package: Reproducible crash
PHP Version: 5.4.8 OS: Gentoo Linux
Private report: No CVE-ID: None
 [2012-10-24 20:48 UTC] phpwnd at gmail dot com
Description:
------------
PHP 5.4.8 + XDebug 2.2.1, no other extensions

I've been experiencing a few segfaults lately. They've been a bit hard to reproduce because so far I've only hit them when using PHP_CodeCoverage and only on specific revisions of my code (adding or removing a single statement such as "$a=1;" would keep it from happening.)

I have gotten around rebuilding PHP with all the debug bells and whistles and the resulting backtrace (hopefully attached to this bug) indicates it's related to GC and/or PCRE. Adding a call to gc_collect_cycles() fixed it for me, at least for now.


Patches

not-a-patch-this-is-a-backtrace (last revision 2012-10-24 20:50 UTC by phpwnd at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-24 23:00 UTC] sixd@php.net
Thanks for the report. Can you continue working on it and:
- Upload a script that reproduces the problem when XDebug is not installed
- Upload build & configuration information
- Try with zend.enable_gc = Off
 [2012-10-24 23:00 UTC] sixd@php.net
-Status: Open +Status: Feedback
 [2012-10-25 05:24 UTC] laruence@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.4-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/

This seems very similar to #63055, which was fixed a short time ago, could you 
please test with the sanpshot of 5.4?
 [2012-10-25 07:06 UTC] phpwnd at gmail dot com
Turning off zend.enable_gc does prevent the crash. I read #63055 before submitting this but I thought the fix went into 5.4.8 and I was hitting a different bug or a case not covered by the fix. Had I realized the fix was for the next version, I would have waited a little more.

I don't have an easy way to install a snapshot to reproduce this crash (which itself requires very specific conditions in my case) and I can't reproduce it without XDebug either. So here's what I'm going to do: I'm going to close this bug for now and I'll reopen it with more info if I can reproduce the crash later.
 [2012-10-25 07:06 UTC] phpwnd at gmail dot com
-Status: Feedback +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 27 12:01:24 2020 UTC