php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63320 Facets not returning results in php, but do in solr Admin
Submitted: 2012-10-21 04:15 UTC Modified: 2014-02-13 18:54 UTC
From: fyb3roptik@php.net Assigned:
Status: Not a bug Package: solr (PECL)
PHP Version: 5.4.8 OS: Debian 6
Private report: No CVE-ID: None
 [2012-10-21 04:15 UTC] fyb3roptik@php.net
Description:
------------
I am using a query in which 1 item is pulled back from solr. If I run the query in 
Solr Admin, then it returns fine showing 1 facet item.

If I run the query using php pecl Solr, then it returns the result but no facet 
items

Test script:
---------------
I can email you a link to see the results if you would like

Expected result:
----------------
I expect for facets to be returned

Actual result:
--------------
No facets come back

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-26 15:40 UTC] eric dot caron at gmail dot com
If you cannot post the code on this ticket, please email them to me.

Also, what version of Solr is the server running, and what version of the PECL extension are you running?
 [2012-10-26 16:01 UTC] fyb3roptik@php.net
Please ignore. I used filter Query and it is working as it should. Cheers for a 
great extension!
 [2014-02-13 18:54 UTC] omars@php.net
-Status: Open +Status: Not a bug
 [2014-02-13 18:54 UTC] omars@php.net
The issue doesn't concern the extension itself.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 09:01:23 2020 UTC