php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63300 cannot load ibm_db2 modules on AIX 6.1.5
Submitted: 2012-10-18 07:14 UTC Modified: 2015-08-18 16:08 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: haoxinf at cn dot ibm dot com Assigned: cmb (profile)
Status: Not a bug Package: Dynamic loading
PHP Version: 5.4.7 OS: AIX 6.1.5
Private report: No CVE-ID: None
 [2012-10-18 07:14 UTC] haoxinf at cn dot ibm dot com
Description:
------------
Hi,

I installed PHP5.4.7 and IBM HTTP Server (IHS) 7. Then build the ibm_db2 with source code v1.9.4 and deployed. But when start IHS, errors are:

PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/freeware/lib/php
/modules/ibm_db2.so' - rtld: 0712-001 Symbol executor_globals was referenced\n
    from module /opt/freeware/lib/php/modules/ibm_db2.so(), but a runtime defini
tion\n      of the symbol was not found. in Unknown on line 0
[Thu Oct 18 14:28:23 2012] [notice] PLUGIN: mod_was_ap22_http: apache_log_header
: WebSphere Plugins loaded.
[Thu Oct 18 14:28:23 2012] [notice] PLUGIN: mod_was_ap22_http: apache_log_header
: --------------------Plugin Information-----------------------
[Thu Oct 18 14:28:23 2012] [notice] PLUGIN: mod_was_ap22_http: apache_log_header
: Bld version: 7.0.0
[Thu Oct 18 14:28:23 2012] [notice] PLUGIN: mod_was_ap22_http: apache_log_header
: Bld date: Aug 19 2008, 23:40:14
[Thu Oct 18 14:28:23 2012] [notice] PLUGIN: mod_was_ap22_http: apache_log_header
: Webserver: IBM_HTTP_Server
[Thu Oct 18 14:28:23 2012] [notice] PLUGIN: mod_was_ap22_http: apache_log_header
: --------------------------------------------------------------
[Thu Oct 18 14:28:23 2012] [notice] Using config file /usr/IBM/HTTPServer/conf/h
ttpd.conf
[Thu Oct 18 14:28:23 2012] [notice] IBM_HTTP_Server/7.0.0.0 (Unix) PHP/5.4.7 con
figured -- resuming normal operations
[Thu Oct 18 14:28:23 2012] [notice] CoreDumpDirectory not set; core dumps may no
t be written for child process crashes

ibm_db2 extension is built with:
./configure --with-IBM_DB2=/opt/IBM/db2/V9.7 --with-php-config=/opt/freeware/bin/php-config

config and make operation are successful.

php -m output below:
root@/opt/freeware/etc>#php -m
[PHP Modules]
bcmath
bz2
Core
ctype
curl
date
dom
ereg
fileinfo
filter
ftp
gd
hash
ibm_db2
iconv
json
libxml
mbstring
mcrypt
mysqli
mysqlnd
openssl
pcre
PDO
pdo_sqlite
Phar
posix
Reflection
session
SimpleXML
soap
sockets
SPL
sqlite3
standard
tokenizer
xml
xmlreader
xmlwriter
zlib

[Zend Modules]

php -v output:
root@/opt/freeware/etc>#php -v
PHP 5.4.7 (cli) (built: Sep 17 2012 11:53:31)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

Fred


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-22 08:18 UTC] haoxinf at cn dot ibm dot com
Using php client, the ibm_db2.so works well:
php -f db2test.php

this command executed successfully, and connected with DB and returned values.

It seems apache cannot load libphp5.so correctly. 

I tested on Apache httpd 2.2.22 and IBM HTTP Server 7(Apache 2.2.8). Both reported: 
PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/freeware/lib/php
/modules/ibm_db2.so' - rtld: 0712-001 Symbol executor_globals was referenced\n
    from module /opt/freeware/lib/php/modules/ibm_db2.so(), but a runtime defini
tion\n      of the symbol was not found. in Unknown on line 0

Please advise. Thank you very much.

Fred
 [2012-10-24 01:17 UTC] haoxinf at cn dot ibm dot com
The PHP5.4.7 installable packages for AIX are downloaded from http://www.perzl.org/aix/index.php.

I only compiled the ibm_db2 extension.

Fred
 [2015-08-18 16:08 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-08-18 16:08 UTC] cmb@php.net
executor_globals is only defined for thread-safe builts. PHP and
modules require matching settings in this regard.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 09:01:31 2024 UTC