php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63262 php.net search IP redirection
Submitted: 2012-10-11 13:19 UTC Modified: 2012-10-12 16:10 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jamie at dr0id dot in Assigned: danbrown (profile)
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS: Windows 7
Private report: No CVE-ID: None
 [2012-10-11 13:19 UTC] jamie at dr0id dot in
Description:
------------
Upon browsing to http://php.net/max-input-time (link copied from php.conf file) 
it's been redirecting me to http://uk1.php.net/manual-lookup.php?
pattern=94.76.225.145max-input-time&lang=en&scope=404quickref which includes an IP 
which resolves to elswick.8086.net

This has happened about 7 or 8 times now. Sometimes I'm sent onto the correct page 
at http://uk1.php.net/manual/en/info.configuration.php#ini.max-input-time but this 
is a minority.

Test script:
---------------
http://php.net/max-input-time

Expected result:
----------------
http://uk1.php.net/manual/en/info.configuration.php#ini.max-input-time

Actual result:
--------------
http://uk1.php.net/manual-lookup.php?pattern=94.76.225.145max-input-
time&lang=en&scope=404quickref

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-11 13:21 UTC] jamie at dr0id dot in
Also had to submit this to "Web Server Problem" Couldn't find the old "Website 
problem" category.
 [2012-10-11 18:02 UTC] jamie at dr0id dot in
Found it -.-
 [2012-10-11 18:02 UTC] jamie at dr0id dot in
-Package: *Web Server problem +Package: Website problem
 [2012-10-11 18:58 UTC] bjori@php.net
Wait. is this still happening for you? It should have been fixed hours ago.

-Hannes
 [2012-10-11 19:06 UTC] jamie at dr0id dot in
Hi Hannes,

The link is still redirecting me to odd places, this time to 

http://uk1.php.net/manual-lookup.php?pattern=87.124.126.4987.124.126.49max-input-
time&lang=en&scope=404quickref

Again, not sure what those IPs are but they're nothing to do with my connection
 [2012-10-12 16:10 UTC] danbrown@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: danbrown
 [2012-10-12 16:10 UTC] danbrown@php.net
I'm seeing the same behavior here.  However, this is essentially a duplicate of 
bug #63259.  Updates will be posted to that bug, and anyone watching this bug is 
encouraged to instead monitor the older bug for progress.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jun 05 21:01:23 2020 UTC