php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #63250 Alternative to mhash_keygen_s2k()?
Submitted: 2012-10-09 18:08 UTC Modified: 2018-02-24 17:46 UTC
Votes:2
Avg. Score:4.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: alix dot axel+php at gmail dot com Assigned: cmb (profile)
Status: Closed Package: hash related
PHP Version: 5.3.17 OS: Ubuntu 12 / Windows 7
Private report: No CVE-ID: None
 [2012-10-09 18:08 UTC] alix dot axel+php at gmail dot com
Description:
------------
The mcrypt_encrypt manual page (http://php.net/manual/en/function.mcrypt-
encrypt.php) says that:

It is recommended to use the mhash functions to create a key from a string.

But the introduction of the mhash manual 
(http://php.net/manual/en/intro.mhash.php) says that:

Note: This extension is obsoleted by Hash.

Here (http://php.net/manual/en/migration53.removed-extensions.php) it also 
stated that:

mhash - Discontinued; use the hash extension instead. hash has full mhash 
compatibility; all existing applications using the old functions will continue 
to work.

-----------------------

The problem is that there's no hash alternative for 
http://www.php.net/manual/en/function.mhash-keygen-s2k.php.

I'm filling this as a documentation bug, but I'm not exactly sure if it should 
be filled in some other category (perhaps feature request?) because at the 
moment we have no other way to do what mhash_keygen_s2k() used to do.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-09 18:18 UTC] alix dot axel+php at gmail dot com
Changed package from mhash to hash.
 [2018-02-24 17:46 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2018-02-24 17:46 UTC] cmb@php.net
> It is recommended to use the mhash functions to create a key
> from a string.

This recommendation has been changed in the meantime (see example
#1). Furthermore the mcrypt extension has been deprecated and
moved to PECL, so this ticket can is obsolete.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 08:03:36 2021 UTC