|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63169 APC dump does not load on another machine
Submitted: 2012-09-27 07:34 UTC Modified: 2013-02-18 00:36 UTC
From: aleemb at gmail dot com Assigned:
Status: No Feedback Package: APC (PECL)
PHP Version: 5.4.7 OS: Windows 7
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2012-09-27 07:34 UTC] aleemb at gmail dot com
I have no issues dumping and loading bin dumps on the same machine, it works 
just fine using dumpfile/loadfile.

However, when moving these dumps over to another machine, the results are mixed. 
Some dumps load just fine all the time while other dumps don't and in fact end 
up crashing httpd.

Both machines are running the same versions of PHP and APC. I am on Windows 7 
and tested this with APC 3.1.13, Apache 2.2 (also tried 2.4), PHP 5.4.7 (also 
tried 5.4.3).

I am dumping files using the full path and on the same machine have verified 
this issue on 4-5 of the machines in my office.

Faulting application name: httpd.exe, version:, time stamp: 0x502f70a3
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x68eab680
Faulting process id: 0xcd0
Faulting application start time: 0x01cd9bbff78d6450
Faulting application path: D:\apache\bin\httpd.exe
Faulting module path: unknown
Report Id: 52bb1201-07b3-11e2-b13f-54424989b320

Expected result:
The dump should load exactly the same on the other machine.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2012-09-27 07:38 UTC]
-Status: Open +Status: Feedback
 [2012-09-27 07:38 UTC]
Do all machines have exactly the same architecture (CPU + x86/x64)?
 [2012-09-27 09:08 UTC] aleemb at gmail dot com
The CPU on both machines is also the same (Intel i5 2410m). Both are running 
Windows 7 x64, Ultimate SP1 (one machines has 4GB RAM, the other has 6GB).
 [2012-09-29 15:14 UTC]

so that's happening under apache. Is it the same on cli?

Also would be very useful to get a piece of code reproducing the fail. Is that any dump you try or some specific code (traits for instance). 

 [2012-10-03 15:09 UTC] aleemb at gmail dot com
The class is being loaded via auto load. The first bug I encountered was that if 
I used require things would break, even on the same machine. By break I mean the 
bin dump would fail to load. Once I replaced the "require" with "include" it 
worked. I just went on this off a hunch, didn't know the two behaved 

The class is part of a bigger application, it's nothing special. It extends and 
another class (however, the parent class is available as is without using a bin 
dump). The class has a few properties and no methods.

The autoloader in use is at
Laravel.Autoloader.html -- I had to change lines 120 and and 124 to "include" 
for it to work even on the same machine.
 [2013-02-18 00:36 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 09 16:05:44 2022 UTC