php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63145 can't compile the externsion fatal errors reported
Submitted: 2012-09-23 23:00 UTC Modified: 2013-01-14 09:58 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:2 (50.0%)
From: simonemandelli at gmail dot com Assigned:
Status: Duplicate Package: bcompiler (PECL)
PHP Version: 5.4.7 OS: raspbian
Private report: No CVE-ID: None
 [2012-09-23 23:00 UTC] simonemandelli at gmail dot com
Description:
------------
pecl install bcompiler
downloading bcompiler-1.0.2.tgz ...
Starting to download bcompiler-1.0.2.tgz (57,347 bytes)
..............done: 57,347 bytes
11 source files, building
running: phpize
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
building in /tmp/pear/temp/pear-build-rootq9IkUU/bcompiler-1.0.2
running: /tmp/pear/temp/bcompiler/configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... armv6l-unknown-linux-gnueabihf
checking host system type... armv6l-unknown-linux-gnueabihf
checking target system type... armv6l-unknown-linux-gnueabihf
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
checking for PHP extension directory... /usr/lib/php5/20100525+lfs
checking for PHP installed headers prefix... /usr/include/php5
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking whether to enable bcompiler support... yes, shared
checking whether to include debug code in bcompiler (default: no)... no
checking how to print strings... printf
checking for a sed that does not truncate output... (cached) /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert armv6l-unknown-linux-gnueabihf file names to armv6l-unknown-linux-gnueabihf format... func_convert_file_noop
checking how to convert armv6l-unknown-linux-gnueabihf file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking for gawk... (cached) nawk
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating ./config.status
config.status: creating config.h
config.status: executing libtool commands
running: make
/bin/bash /tmp/pear/temp/pear-build-rootq9IkUU/bcompiler-1.0.2/libtool --mode=compile cc  -I. -I/tmp/pear/temp/bcompiler -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rootq9IkUU/bcompiler-1.0.2/include -I/tmp/pear/temp/pear-build-rootq9IkUU/bcompiler-1.0.2/main -I/tmp/pear/temp/bcompiler -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/bcompiler/php_bcompiler.c -o php_bcompiler.lo
libtool: compile:  cc -I. -I/tmp/pear/temp/bcompiler -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rootq9IkUU/bcompiler-1.0.2/include -I/tmp/pear/temp/pear-build-rootq9IkUU/bcompiler-1.0.2/main -I/tmp/pear/temp/bcompiler -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/bcompiler/php_bcompiler.c  -fPIC -DPIC -o .libs/php_bcompiler.o
/tmp/pear/temp/bcompiler/php_bcompiler.c: In function '_bcompiler_write_functions_from_file':
/tmp/pear/temp/bcompiler/php_bcompiler.c:468:6: warning: passing argument 1 of 'apc_serialize_zstring' discards 'const' qualifier from pointer target type [enabled by default]
/tmp/pear/temp/bcompiler/php_bcompiler.h:298:6: note: expected 'char *' but argument is of type 'const char *'
/tmp/pear/temp/bcompiler/php_bcompiler.c: In function 'zif_bcompiler_write_file':
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:10: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:574:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:581:5: warning: passing argument 4 of 'apc_serialize_zend_class_entry' discards 'const' qualifier from pointer target type [enabled by default]
/tmp/pear/temp/bcompiler/php_bcompiler.h:305:6: note: expected 'char *' but argument is of type 'const char *'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:10: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
/tmp/pear/temp/bcompiler/php_bcompiler.c:635:24: error: 'zend_class_entry' has no member named 'filename'
make: *** [php_bcompiler.lo] Error 1
ERROR: `make' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-16 21:25 UTC] diego at pagodabox dot com
Experienced this same error on Ubuntu 12.04.  Only seems to be accepting this 
version of PHP.
 [2013-01-14 09:23 UTC] jandanson at soloeurope dot com
Please, can someone fix this and mark as duplicate of issue #60618
 [2013-01-14 09:58 UTC] alan_k@php.net
-Status: Open +Status: Duplicate
 [2013-01-14 09:58 UTC] alan_k@php.net
dupe of  #60618
 [2013-06-18 16:30 UTC] vahidhwp at gmail dot com
Hi,
Try to compile PHP 5.3 from http://php.net/downloads.php . The bcompiler package didn't work with PHP 5.4 package.

and here is the complete solution:

Install php 5.3.26

Intall BCompiler1.0.9 from source code on ubuntu 12.10:
1-download latest version from http://pecl.php.net/package/bcompiler
2- extract archive: # tar xzvf bcompiler-1.0.2.tgz
3- # cd bcompiler-1.0.2
4- # type php : php is hashed (/usr/local/bin/php)
5- # export PHP_PREFIX=/usr/local/bin/php
6- # phpize
7- #  ./configure --enable-bcompiler
8- # make
9- # make test
10-# make install
11-# sudo gedit /etc/php5/apache2/php.ini
12- add last to line and close: extension=bcompiler.so
13-# service apache2 restart
14- make a test.php containing: <?php phpinfo();?> and check bcompiler extension

Best Regards
Vahid Moslemi
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jun 03 06:01:30 2020 UTC