php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63090 Bcompiler error, undefined symbol: bcompiler_set_stdsize, Suse 12.1,php 5.3.8
Submitted: 2012-09-14 13:50 UTC Modified: 2013-02-18 00:36 UTC
Votes:4
Avg. Score:4.0 ± 1.0
Reproduced:4 of 4 (100.0%)
Same Version:1 (25.0%)
Same OS:2 (50.0%)
From: lukwago at magezi dot net Assigned:
Status: No Feedback Package: bcompiler (PECL)
PHP Version: 5.3.17 OS: Suse 12.1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2012-09-14 13:50 UTC] lukwago at magezi dot net
Description:
------------
I tried the latest version of bcompiler, 1.0.2 and 0.8 and another earlier verion, they installed successfully to writing in the php.ini but upon restarting apache I would get the same error. And actually appache would not start not until I comment out the extension=bcompiler.so

Below is the error line I get in the error log.
/usr/sbin/httpd2: symbol lookup error: /usr/lib64/php5/extensions/bcompiler.so: undefined symbol: bcompiler_set_stdsize

Please advise.

Expected result:
----------------
I would think that you may look at that line where that vairiable is being used, probably it should be define somewhere.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-02-09 18:38 UTC] thomas at omerzu dot de
Obviously, the compiler has some problems with the inline definition
of bcompiler_set_stdsize:

In file included from /home/omerzu/bcompiler-1.0.2/php_bcompiler.c:22:0:
/home/omerzu/bcompiler-1.0.2/php_bcompiler.h:289:13: warning: inline function 'bcompiler_set_stdsize' declared but never defined [enabled by default]
/home/omerzu/bcompiler-1.0.2/bcompiler.c:31:44: warning: '_stdsize_05' is static but used in inline function 'bcompiler_set_stdsize' which is not static [enabled by default]
/home/omerzu/bcompiler-1.0.2/bcompiler.c:31:30: warning: '_stdsize_03' is static but used in inline function 'bcompiler_set_stdsize' which is not static [enabled by default]

I was able to correct the problem by just removing the "inline" in front
of the bcompiler_set_stdsize definition in file bcompiler.c
This might not be optimal, but seem to wort.
 [2013-02-10 19:49 UTC] val@php.net
-Status: Open +Status: Feedback
 [2013-02-10 19:49 UTC] val@php.net
Could you please provide the C compiler version you use? Please type "gcc -v" and "gcc --version" at the command prompt and quote the output. Since the code works fine at my system, I suspect the problem is related to a minor incompatibility between a newer gcc version used on Suse 12.1
 [2013-02-18 00:36 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 00:01:34 2019 UTC