php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63047 Easter date is wrong
Submitted: 2012-09-09 09:46 UTC Modified: 2012-09-09 17:01 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: aschenaz at gmail dot com Assigned:
Status: Not a bug Package: Calendar related
PHP Version: 5.4.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aschenaz at gmail dot com
New email:
PHP Version: OS:

 

 [2012-09-09 09:46 UTC] aschenaz at gmail dot com
Description:
------------
Asking for Easter date function, it will result Apr-07-2012, but it should be Apr-08-2012! That is important for liturgic year calculations.

Test script:
---------------
<?php
echo date("M-d-Y", easter_date());
?>


Expected result:
----------------
Apr-08-2012

Actual result:
--------------
Apr-07-2012

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-09-09 11:55 UTC] aschenaz at gmail dot com
It was my fault. With the last upgrade of php, php.ini (with a timezone set) was been overwritten and now it had no timezone.
I beg your pardon.
 [2012-09-09 11:55 UTC] aschenaz at gmail dot com
-Status: Open +Status: Closed
 [2012-09-09 17:01 UTC] rasmus@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Apr 05 02:01:23 2020 UTC