php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63038 Unable to Compile
Submitted: 2012-09-07 17:36 UTC Modified: 2017-04-01 21:09 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: pristine dot source at gmail dot com Assigned:
Status: Wont fix Package: Paradox (PECL)
PHP Version: 5.4.6 OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2012-09-07 17:36 UTC] pristine dot source at gmail dot com
Description:
------------
When compiling it gets errors like so:

...
/paradox-1.4.3/paradox.c  -fPIC -DPIC -o .libs/paradox.o
/home/pristine/php_modules/paradox-1.4.3/paradox.c:51: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'paradox_functions'
/home/pristine/php_modules/paradox-1.4.3/paradox.c:92: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'paradox_funcs_db'
/home/pristine/php_modules/paradox-1.4.3/paradox.c:138: error: 'paradox_functions' undeclared here (not in a function)
/home/pristine/php_modules/paradox-1.4.3/paradox.c: In function 'paradox_object_new':
/home/pristine/php_modules/paradox-1.4.3/paradox.c:286: error: 'zend_class_entry' has no member named 'default_properties'
/home/pristine/php_modules/paradox-1.4.3/paradox.c: In function 'zm_startup_paradox':
/home/pristine/php_modules/paradox-1.4.3/paradox.c:309: error: 'paradox_funcs_db' undeclared (first use in this function)
/home/pristine/php_modules/paradox-1.4.3/paradox.c:309: error: (Each undeclared identifie
...


I have a patch ready to fix this and I will include it here with this bug.

Expected result:
----------------
It compiles without error.

Actual result:
--------------
It gives compile errors.

Patches

paradox-1.4.3_PHP54.patch (last revision 2012-09-07 17:36 UTC by pristine dot source at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:09 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:09 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2007, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Oct 22 13:01:29 2019 UTC